go_away

Author Topic: H-Bridge  (Read 896 times)

0 Members and 1 Guest are viewing this topic.

Offline Martin1512Topic starter

  • Jr. Member
  • **
  • Posts: 8
  • Helpful? 0
H-Bridge
« on: March 26, 2010, 02:45:45 PM »
Hi, I am making my first robot(line follower), i found good Mosfer H-Bridge DC Motor : http://schematics.circuitdiagram.net/viewer.php?id=cqs1235544146p.jpg

 I just found little problem, schematics says that i need 18Volts for VCC but i have only 6V and dont want to use more, can i implement it without changing of resistor values or should i decrease values of resistors (let's say divide them by 3   (18/6)).

Question 2 : I was reading in some web-page  that mosfets can get super hot and they need cooler, is it true ? If yes, what cooler
Thanks :)
« Last Edit: March 26, 2010, 02:49:29 PM by Martin1512 »

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,943
  • Helpful? 98
Re: H-Bridge
« Reply #1 on: March 26, 2010, 04:46:03 PM »
A very good reason to need the higher voltage is that the MOSFETs in the link require 10V from Gate to Source to fully turn on. Changing the resistor values won't help. Here is the data sheet of the N-ch MOSFET:
http://pdf1.alldatasheet.com/datasheet-pdf/view/22410/STMICROELECTRONICS/IRFZ40.html

Yes, depending on several factors MOSFETs can get hot. Cooling them is normally done by thermally connecting them to a heatsink (commonly a black finned thingy) and maybe even have a fan blowing air over the heatsink.

These are fairly old MOSFETs and there are newer one now available that will work with 6V. Also there is another thread currently running on building your own H-bridge here:
http://www.societyofrobots.com/robotforum/index.php?topic=10722.0
That should be helpful.

Offline guru

  • Full Member
  • ***
  • Posts: 59
  • Helpful? 1
  • Robotics, CNC, Electronics, Programming
Re: H-Bridge
« Reply #2 on: March 27, 2010, 06:05:59 AM »
I think this is the circuit diagram I couldnt get to work. The mosfets got super hot since the resistors keep the mosfets from not fully turning on...or off! I was using the IRF 530/9530 mosfets instead though. maybe there is a difference there.

Either way, it's not going to perform well. Those resistors and single stage transistor is not going to push or drain enough charge into and out of the mosfets.
« Last Edit: March 27, 2010, 06:08:12 AM by guru »

Offline Martin1512Topic starter

  • Jr. Member
  • **
  • Posts: 8
  • Helpful? 0
Re: H-Bridge
« Reply #3 on: March 27, 2010, 10:12:08 AM »
Well I found this circuit http://www.mcmanis.com/chuck/robotics/tutorial/h-bridge/bjt-circuit.html

Its not mosfet but normal transistor, i found all parts at home and it works fine for me. For my first robot is it enough :)

Thanks

 


Get Your Ad Here