Author Topic: CrossPack (AVRDude) is not working, what am I doing wrong?  (Read 2215 times)

0 Members and 1 Guest are viewing this topic.

Offline TheStoneTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
CrossPack (AVRDude) is not working, what am I doing wrong?
« on: April 11, 2010, 02:42:13 AM »
Hi

I have been working on the 50$ robot tutorial (using an ATMEGA328), but when I come to connecting it to the computer it fails.
I am using the AVRISP MK2 and it is plugged in to the computer and the micro controller, I also have a 6 volts (charged) battery connected.
The red LED on the AVRISP turns on.
I create a project as shown in the CrossPack docs, my MakeFile settings are these:

DEVICE     = atmega328p
CLOCK      = 20000000
PROGRAMMER = -c avrisp2 -P usb
OBJECTS    = main.o
FUSES      = -U lfuse:w:0x62:m -U hfuse:w:0xd9:m -U efuse:w:0xff:m


I run command "Make"
Runs fine, the main.hex and .elf files are created.

Then I try to run Make flash, I see a LED flashing inside the AVRISP (not the big red LED), but here's the output.

Arbets-iMac:firmware arong$ make flash
avrdude -c avrisp2 -p m328p -U flash:w:main.hex:i
avrdude: ser_open(): can't open device "unknown": No such file or directory
make: *** [flash] Error 1


However I tried creating a new project from scratch, and now I get this error:

avrdude -c avrisp2 -P usb -p atmega328p -U flash:w:main.hex:i

avrdude: stk500v2_command(): command failed
avrdude: stk500v2_command(): unknown status 0xc9
avrdude: stk500v2_program_enable(): cannot get connection status
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

make: *** [flash] Error 1



Does anyone know what I am doing wrong?

Thanks,
Aron

 


Get Your Ad Here

data_list