Author Topic: I am using 12v battery to power 18 servos.  (Read 1472 times)

0 Members and 1 Guest are viewing this topic.

Offline bilalsTopic starter

  • Full Member
  • ***
  • Posts: 81
  • Helpful? 0
I am using 12v battery to power 18 servos.
« on: May 13, 2010, 01:30:18 AM »
Hello,

You might remember my earlier posts regarding the reseting of Axon II with 18 servos connected. I have tried connecting up till four 6V batteries in parallel, but didn't work. Yesterday i connected two of the 6V batteries in series (hence 12V) and I am really surprised from the results. Axon does not reset anymore at all. In addition to that, my robot couldn't possibly stand up using the previous configuration but can easily now. I powered it for like 2 minutes or so. I was afraid the servos will fry or something. During the 2 minutes I checked how hot the servos were by touching them, and they appeared to be totally normal.

I am not really sure if this is the best way to do it but it fixed my problem, although i know that the servos operate at 6V or so. Is it okay to continue using it this way as long as the servos are not overheating ?

BTW, for the case where the Axon used to reset, i have measured the voltage using the oscilloscope (different intervals in ms,us,ns) while axon resetting. The voltage is not dropping suddenly and the minimum it goes to is 6.0V (usually around 6.5).
« Last Edit: May 13, 2010, 02:21:38 AM by bilals »

Offline amando96

  • Robot Overlord
  • ****
  • Posts: 187
  • Helpful? 1
Re: I am using 12v battery to power 18 servos.
« Reply #1 on: May 13, 2010, 05:56:42 AM »
I REALLY doubt the servos will last long like that  :-\
Rorcle, 60% complete
AATV, 5% complete

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,941
  • Helpful? 98
Re: I am using 12v battery to power 18 servos.
« Reply #2 on: May 13, 2010, 07:43:55 AM »
If your wiring is correctly built your servos should work fine with just 6V. Therefore there is some thing wrong with the wire and connections from the battery to the servos.

Remember Ohm's LAW? E = IR would be the amount the Voltage drops across a R with I amount of current. Since 12V is not burning out the servos then the voltage must have dropped to a safe voltage for the servos. Any piece of wire and each connection has resistance and would sum together for the R in Ohm's Law. And with the high current pulled by 18 servos it won't take much R to drop 6 Volts. A half Ohm with 12Amps of current will drop 6Volts.

So, recheck how you have wired the battery to the servos.
Is the wire gauge heavy enough?
Are the connections good (solder joints)?
Are there any connectors? What is the contact resistance?

Post some pictures of the wiring and connectors so we can make suggestions.
« Last Edit: May 13, 2010, 08:37:28 AM by waltr »

Offline romick

  • Jr. Member
  • **
  • Posts: 7
  • Helpful? 0
Re: I am using 12v battery to power 18 servos.
« Reply #3 on: May 18, 2010, 12:21:17 AM »

Offline TrickyNekro

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 1,207
  • Helpful? 15
  • 1.6L Peugeot 307 tuner
Re: I am using 12v battery to power 18 servos.
« Reply #4 on: May 18, 2010, 04:47:32 AM »
You have a huge voltage drop... from 12V to 6v??? It's kinda WOW!

Wiring is barely a problem... These wires have only some mOhms of resistance...

I would check my batteries and how they behave under load...
This behavior shows either discharged or destroyed batteries...

Then again you can check your charger if it charges correctly the batteries...
18 servos is much....
So I would try splitting the power of the batteries to different servos...
The batteries may not be able to handle all the current the servos need...
So let's say you have 3 batteries then, one battery should only power 6 servos and so on...
Just keep the ground common and you shall have no problem at all...
Paralleling the power sources DOES require more than just connecting the batteries in parallel... Most of the batteries for different reasons won't have the same charge, and this could lead to current leaking between the batteries... And that's something you don't want to... Could also lead to battery destruction...

So... things seem to be that way for you... should you reply with an update ;-)

Best Regards, Lefteris
Greece
For whom the interrupts toll...


P.S. I've been inactive for almost a year... Don't give promises but I'll try to complete my tutorials. I'll let you know when..

Cheers!

Offline Soeren

  • Supreme Robot
  • *****
  • Posts: 4,672
  • Helpful? 227
  • Mind Reading: 0.0
Re: I am using 12v battery to power 18 servos.
« Reply #5 on: May 18, 2010, 08:20:34 AM »
Hi,

Go back to 6V immediately and then add the caps needed and clean up your wiring.
Should the 12V go directly to a servo, it won't live long.

Which voltage regulator do you use?
Regards,
Søren

A rather fast and fairly heavy robot with quite large wheels needs what? A lot of power?
Please remember...
Engineering is based on numbers - not adjectives

 


Get Your Ad Here