Author Topic: 50$ robot> final step... programing  (Read 3414 times)

0 Members and 1 Guest are viewing this topic.

Offline razvanc_roroTopic starter

  • Jr. Member
  • **
  • Posts: 41
  • Helpful? 0
50$ robot> final step... programing
« on: May 16, 2007, 01:17:22 PM »
Hello again!

Now I have another problem with my robot. I rebuild the project in AVRStudio, all goes well, 0 errors, making the .hex ok;
in PonyProg, I open the .hex and give "Write All" and when it starts I hear the left servo "moaning" and before it starts the writing progress I get the "Device missing or unknown device (-24)" error. If I click Retry I get the same answer from the PC and also from the robot; if I click Ignore, I see the other progress bars going to 100%, at the end verifying ok, and getting the message finally "Write failed". I mention that the Interface Setup Probe and the Calibration Probe went OK...

Hope you understand what I was talking about and especialy some of you give me usefull advices :)
Thank you!
« Last Edit: May 16, 2007, 01:50:07 PM by razvanc_roro »
Try do your best without doing anything! Possible?!?

Offline ed1380

  • Supreme Robot
  • *****
  • Posts: 1,478
  • Helpful? 3
Re: 50$ robot> final step... programing
« Reply #1 on: May 16, 2007, 01:38:06 PM »
that's more than what I was able to get out of mine
are you using the cable admin recomended getting? if so he says there is some problem with it
Problems making the $50 robot circuit board?
click here. http://www.societyofrobots.com/robotforum/index.php?topic=3292.msg25198#msg25198

Offline razvanc_roroTopic starter

  • Jr. Member
  • **
  • Posts: 41
  • Helpful? 0
Re: 50$ robot> final step... programing
« Reply #2 on: May 16, 2007, 01:46:41 PM »
I'm using a "usual" cable on serial port (not a programmer) (probably this is the cause... :D ).
I thought it could go with this... hope I'm not wrong...
Waiting for more oppinions... :)
Try do your best without doing anything! Possible?!?

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,659
  • Helpful? 169
    • Society of Robots
Re: 50$ robot> final step... programing
« Reply #3 on: May 16, 2007, 01:56:49 PM »
you are using the AVR STK Serial Port Dongle Programmer from sparkfun.com, right?

towards the bottom of the tutorial you will see:

If you didn't select the correct port to use for your programmer (because you still aren't sure), or you forgot to turn your robot on, you will get this error:



Try plugging in your programmer to a different port of your computer and then push Retry. Try each COM port until it works.



Tried that yet? :P

Offline razvanc_roroTopic starter

  • Jr. Member
  • **
  • Posts: 41
  • Helpful? 0
Re: 50$ robot> final step... programing
« Reply #4 on: May 16, 2007, 02:47:57 PM »
I want to use AVR STK Serial Port Dongle Programmer but it's problematic with the shipment and I don't wanna wait 2 weeks for sparkfun.com to send here (Bucharest, Romania).
I am using (used) a simple cable as I said (the header from robot's motherboard with 10pin holes and at the other end a 9 pin holes header (for serial port)) and I repeat i don't think this is called a "programmer"... :) I guess the "programmer" has some functions, electronics in addition.

I have only one serial port on my PC... so I can't miss... I'm using COM1 alright... :)

I'm thinkink of some way getting that programmer...
« Last Edit: May 16, 2007, 02:48:57 PM by razvanc_roro »
Try do your best without doing anything! Possible?!?

Offline ed1380

  • Supreme Robot
  • *****
  • Posts: 1,478
  • Helpful? 3
Re: 50$ robot> final step... programing
« Reply #5 on: May 16, 2007, 03:25:16 PM »
O that wont work, there is some circuitry inside tht cable from sparkfun.
BTW is took them 1 week to ship within the states

might look into something like this http://www.instructables.com/id/E5H5UDWB5UEUKIKV8V/
Problems making the $50 robot circuit board?
click here. http://www.societyofrobots.com/robotforum/index.php?topic=3292.msg25198#msg25198

Offline razvanc_roroTopic starter

  • Jr. Member
  • **
  • Posts: 41
  • Helpful? 0
Re: 50$ robot> final step... programing
« Reply #6 on: May 16, 2007, 04:14:39 PM »
Thanks for the advice and link. I hope i'm gonna find that programmer fast and... accesible. :)
Try do your best without doing anything! Possible?!?

Offline harrythepotter2007

  • Jr. Member
  • **
  • Posts: 15
  • Helpful? 0
Re: 50$ robot> final step... programing
« Reply #7 on: September 03, 2008, 03:56:50 AM »
I want to use AVR STK Serial Port Dongle Programmer but it's problematic with the shipment and I don't wanna wait 2 weeks for sparkfun.com to send here (Bucharest, Romania).
I am using (used) a simple cable as I said (the header from robot's motherboard with 10pin holes and at the other end a 9 pin holes header (for serial port)) and I repeat i don't think this is called a "programmer"... :) I guess the "programmer" has some functions, electronics in addition.

I have only one serial port on my PC... so I can't miss... I'm using COM1 alright... :)

I'm thinkink of some way getting that programmer...


Not to mention it costs 95$ for the transport

 


Get Your Ad Here

data_list