go_away

Author Topic: Adding webbotlib to eclipse  (Read 1174 times)

0 Members and 1 Guest are viewing this topic.

Offline tmoney68Topic starter

  • Jr. Member
  • **
  • Posts: 35
  • Helpful? 1
Adding webbotlib to eclipse
« on: July 12, 2010, 11:20:03 PM »
Since I am strictly a linux user, I have decided to play around with Eclipse. I have downloaded the current version and installed the AVR plugin. It seems to work very nicely. My question is how to include webbotlib? Has anyone done this? Its probably an easy solution, but I can't seem to figure it out.

Thanks in advance

Offline Webbot

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 2,132
  • Helpful? 109
Re: Adding webbotlib to eclipse
« Reply #1 on: July 13, 2010, 10:28:36 AM »
Have you read Dunks tutorial at http://www.societyofrobots.com/member_tutorials/node/381

Does that help?
Webbot Home: http://webbot.org.uk/
WebbotLib online docs: http://webbot.org.uk/WebbotLibDocs
If your in the neighbourhood: http://www.hovinghamspa.co.uk

Offline dunk

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 1,086
  • Helpful? 21
Re: Adding webbotlib to eclipse
« Reply #2 on: July 13, 2010, 11:59:15 AM »
Have you read Dunks tutorial at http://www.societyofrobots.com/member_tutorials/node/381

Does that help?

that doc does not cover Eclipse.
but it is good background reading.


so presuming you know how to include WebbotLib from the command line it's pretty easy.

in Eclipse, open your project then go
Project -> Properties -> C/C++ Build -> Settings .
then under Tool Settings point to the various WebbotLib directories and the libWebbot-ATMegaXXXX.a file under the relevant sub sections as you would from the command line.


dunk.

Offline tmoney68Topic starter

  • Jr. Member
  • **
  • Posts: 35
  • Helpful? 1
Re: Adding webbotlib to eclipse
« Reply #3 on: July 13, 2010, 01:34:04 PM »
Thanks, I knew it would be something simple!

Offline Drod

  • Beginner
  • *
  • Posts: 2
  • Helpful? 0
Re: Adding webbotlib to eclipse
« Reply #4 on: January 26, 2011, 08:07:40 PM »
Hi Dunk! Hi tmoney!

I'm new to all of this (including use Ubuntu for programming AVR's), and I don't know how to include WebbotLib from the command line / Eclipse..  ???

I only achieved to use AVR plugin with Eclipse  :-X

Please, can you make a Step-by-step tuto?

Thanks in advance!


 


Get Your Ad Here

data_list