go_away

Author Topic: Eagle3d Macro  (Read 1206 times)

0 Members and 1 Guest are viewing this topic.

Offline chapsTopic starter

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
Eagle3d Macro
« on: August 04, 2010, 11:48:29 AM »
Help the Newby!!!

I'm using Eagle and POV-ray to render a board.  I was using an NE555 but found the part did not appear on the board.  I found a great tutorial on this site regarding creating the part.  Followed it carefully but having a problem.

3dusrpac.dat
DIL-08:0:1:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:0:IC_DIS_DIP8(::

I used the PACKAGE DIL-08 AND THE MACRO :

user.inc
#macro IC_DIS_DIP8(name,logo) 
   union{
object{IC_DIS_DIP_GRND(8,8,3,3.2,name,logo)} 
   {
#end

When I try to render it I get a parsing error "expected 2 parameters but only found one"  This is the line of code, error in RED:

#ifndef(pack_U1) #declare global_pack_U1=yes; object {IC_DIS_DIP8("NE555",)translate<0,0,0> rotate<0,0.000000,0>rotate<0,-270.000000,0> rotate<0,0,0> translate<25.400000,0.000000,43.180000>}#end      //  U1 NE555 DIL-08
}//End union

It appears that the "logo" is the missing parameter.  How do I solve the missing parameter problem????

Thanks in advance!
#end

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,632
  • Helpful? 169
    • Society of Robots
Re: Eagle3d Macro
« Reply #1 on: August 14, 2010, 08:45:00 PM »
I never really figured out this error either.

I usually just delete an item, such as logo, and the error goes away.

For example, #macro IC_DIS_DIP8(name)

Sorry I couldn't be of more help!

 


Get Your Ad Here