go_away

Author Topic: New on Robots.. Some Doubts...  (Read 1582 times)

0 Members and 1 Guest are viewing this topic.

Offline OdelotTopic starter

  • Beginner
  • *
  • Posts: 2
  • Helpful? 0
New on Robots.. Some Doubts...
« on: June 03, 2007, 02:04:09 PM »
Hi,

I am Brazillian, new on forum (first post) and I am trying yo start on robotics. I am a programmer, so i have a lot of doubts on eletronics...

I am working with Nintendo DS (to use the wireless feature) to control my future Robo and projects.. ah, I am using Pic as microcontroller (i already made a recorder for PIC)

I already made a circuit with Pic, Transistors and Serial communicaton with PC to control simple DC motors with PIC

well, i have some newbe doubts:

1. How can i use one power source to motors and other for circuits??? i tried to put a power source on collector and emmiter of my transistor and use the base with the pic signal  (that is using the other power source) and it didnt work

2. What is the easiest way to control voltage on a circuit. I have a power source that provides 15V and 500mA (used on pic recorder) and i want to use it for motors and circuits... for the PIC, i am using the L7805, but with this power source it gets very heat (so i am using a 9V battery)... and for others voltages, can i control it with common components??? (i am trying to understand shunt voltage regulater and there is that LM317, but what is the best and more flexible to start little experiments??)

well.. i think that my main doubts are these ones...

if any of you needs help on programming, hehe, in this area I can help you! so, if you need, just ask and I will try to help you. I work mainly with java, c, c++ and Opengl...

thanks in advance

PS: sorry about english errors...

PS2: a really nice obo project, using DS, can be found here http://www.natrium42.com/robot/ You can control his Robo via Internet
« Last Edit: June 03, 2007, 02:14:19 PM by Odelot »

Offline hazzer123

  • Supreme Robot
  • *****
  • Posts: 460
  • Helpful? 3
Re: New on Robots.. Some Doubts...
« Reply #1 on: June 04, 2007, 03:12:07 AM »
About the transistor - I think that the ground or negative voltage must go at the emitter and the collector must be connected to the positive voltage. Also, if you are using two power supplies, then they must share a common negative voltage. You do this by simply connecting up their negative terminals together.

If that didnt work, then maybe its a broken transistor?
Imperial College Robotics Society
www.icrobotics.co.uk

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: New on Robots.. Some Doubts...
« Reply #2 on: June 08, 2007, 01:26:08 PM »
http://www.societyofrobots.com/schematics_powerregulation.shtml

Oh and dont use transistors, use MOSFETS, they rock! ;D

 


Get Your Ad Here