go_away

Author Topic: Servos move when power on  (Read 829 times)

0 Members and 1 Guest are viewing this topic.

Offline enekuxTopic starter

  • Jr. Member
  • **
  • Posts: 23
  • Helpful? 0
Servos move when power on
« on: December 28, 2010, 08:49:20 AM »
Hi! I am having some minor problems with the starting up of my robot.

In general, when I power on the system the servos move. It is just a little buzz, but still, I would like to avoid it. Actually I have tested the servos separately from the whole system and it keeps doing the same. Every time I power them on they buzz. At that point I have to say that it doesn't matter if the power is regulated or not, because still it does the same, so using capacitors for preventing low and high frequency voltage disturbances (in power on) does not solve the problem...

The servos have being modified for continuous rotation...

One guy had the idea of adding a delay circuit based on a 555 IC and a relay, that powers up the servos after a 1.5sec delay - enough for them to "miss" this jolting phase.

http://www.rc-cam.com/forum/index.php?/topic/3523-servo-glitches-while-pic-boots/

Any ideas/recommendations?? Do you also have this phase in start up??

Thanks!
« Last Edit: December 28, 2010, 09:05:09 AM by enekux »

Offline enekuxTopic starter

  • Jr. Member
  • **
  • Posts: 23
  • Helpful? 0
Re: Servos move when power on
« Reply #1 on: December 28, 2010, 09:04:08 AM »
Admin?!! Have you changed my reply to this new topic??  sorry if I did not do right! ???

...by the way do you have any idea about what I am saying?
« Last Edit: December 28, 2010, 09:05:31 AM by enekux »

Offline VegaObscura

  • Robot Overlord
  • ****
  • Posts: 153
  • Helpful? 6
Re: Servos move when power on
« Reply #2 on: December 28, 2010, 01:47:58 PM »
Do you mean your servos jerk for an instant when power is applied, and then stop?  Or they are constantly moving a little when power is on to them?  If its the former, this is entirely normal.  If its the latter, and they constantly move a little when power is on even if they aren't connected to a microcontroller, then you have faulty servos.

Offline enekuxTopic starter

  • Jr. Member
  • **
  • Posts: 23
  • Helpful? 0
Re: Servos move when power on
« Reply #3 on: December 28, 2010, 02:14:41 PM »
Yes they move just a bit when the power is on!After that everything is ok, but... there is no way to avoid it?? It results a bit anoying for me...

thanks!

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: Servos move when power on
« Reply #4 on: December 28, 2010, 06:29:30 PM »
The servo jerk is hard to avoid . . . but make sure that your code keeps all the signal lines low asap during power up to reduce the effects.

The problem occurs when voltage rushes into the system and has not yet settled at a stable proper binary voltage.

Offline enekuxTopic starter

  • Jr. Member
  • **
  • Posts: 23
  • Helpful? 0
Re: Servos move when power on
« Reply #5 on: December 29, 2010, 02:28:20 AM »
Aha I see! Well I won't bother any more about this issue because as I said it is a minor problem... still if I have any news I will let you know!

Thank you!!

 


Get Your Ad Here

data_list