go_away

Author Topic: configuring tera term for axonII  (Read 1559 times)

0 Members and 1 Guest are viewing this topic.

Offline BANETopic starter

  • Supreme Robot
  • *****
  • Posts: 639
  • Helpful? 4
  • E=roboticsC^2
configuring tera term for axonII
« on: January 17, 2011, 09:40:34 PM »
hello all,
the subject pretty much says it all.  it looks like im getting a lot of garbage.  I'm using vista 32 bit so that shouldn't be a problem.  I'm new to tera term so i'm hoping i have the configuration wrong.  does anyone know what the configuration should be?  All so, after reading up on similar problems, the battery currently on charge although i don't think it was anywhere near dead :P

pic of current config

thnx

Offline hopslink

  • Robot Overlord
  • ****
  • Posts: 202
  • Helpful? 14
Re: configuring tera term for axonII
« Reply #1 on: January 18, 2011, 03:19:07 AM »
It may look like garbage but it's not, you can see there is structure.

First thing to do is check that your baud rates are correctly configured as a mismatch can give you 'garbage'.

It is also likely that this is your terminal program trying to represent the bytes you are sending as ascii. If you are sending text then you should have a look at how you are 'printing' that data to the UART. If you are sending binary data then you are better off viewing it as hex or binary. If Tera Term does not give you this option then grab RealTerm or some other terminal that does.

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: configuring tera term for axonII
« Reply #2 on: January 18, 2011, 09:18:46 AM »
Seemingly random bizarre characters means a mis-matched baud rate.

Change the baud of your terminal program to 230400, which is the default for the Axon.



edit: I got the 3 and 4 reversed, oops!
« Last Edit: January 18, 2011, 12:11:28 PM by Admin »

Offline BANETopic starter

  • Supreme Robot
  • *****
  • Posts: 639
  • Helpful? 4
  • E=roboticsC^2
Re: configuring tera term for axonII
« Reply #3 on: January 18, 2011, 09:37:43 AM »
you're a life saver admin. it works now!  its actually "230400" probably tipo.  the only reason i used the other baud rate is that what was on the hyperterm tut, but i guess there different.

another thing; what should flow control be set too?  it works fine on "none"

thnx

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,935
  • Helpful? 98
Re: configuring tera term for axonII
« Reply #4 on: January 18, 2011, 10:27:22 AM »
Ahh good, a simple Baud rate fix.

Flow control set to NONE is the most common used and works 99.99% of the time.

Hardware Flow control requires to use of the CTS & RTS lines which are not normaly supported in hardware on most u-controller's UARTs.

Software Flow control does work if you are sending binary data. This is two 7bit codes that stop and start data flow. You would also need to handle this with code in your u-controller.

If you send a huge amount of data at one time that could overflow the data buffer then Flow control is needed. Else just set it to NONE.

 


Get Your Ad Here