Author Topic: Trouble with Project Designer makefile for Axon 2  (Read 875 times)

0 Members and 1 Guest are viewing this topic.

Offline Crunchy TheoryTopic starter

  • Full Member
  • ***
  • Posts: 80
  • Helpful? 0
  • "Well great is ok, but amazing would be great."
Trouble with Project Designer makefile for Axon 2
« on: January 22, 2011, 01:34:27 PM »
Has anyone gotten this error when trying to compile using Project Designer's generated makefile for Axon2?

Crunchy-10:Axon2 Crunchy$ make
avr-ar -r lib/libPost.a
avr-ar: lib/libPost.a: No such file or directory
make: *** [lib/libPost.a] Error 1

I'm using webbotlib v1.28 and I thought I've successfully built using the generated makefile before, but maybe that was using webbotlib v1.27. I'm not sure if it makes a difference.
The only way to top an upright screen, keyboard, and mouse is to eliminate the need for humans to touch a PC at all. Oh, hello there Mr. Robot... what would I like you to do, you ask?

Offline Webbot

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 2,132
  • Helpful? 108
Re: Trouble with Project Designer makefile for Axon 2
« Reply #1 on: January 22, 2011, 07:09:52 PM »
ok I'm on it - In the meantime just try creating the 'lib' subdirectory in your project folder and see if that works.
Webbot Home: http://webbot.org.uk/
WebbotLib online docs: http://webbot.org.uk/WebbotLibDocs
If your in the neighbourhood: http://www.hovinghamspa.co.uk

Offline Crunchy TheoryTopic starter

  • Full Member
  • ***
  • Posts: 80
  • Helpful? 0
  • "Well great is ok, but amazing would be great."
Re: Trouble with Project Designer makefile for Axon 2
« Reply #2 on: January 23, 2011, 06:23:19 PM »
ok I'm on it - In the meantime just try creating the 'lib' subdirectory in your project folder and see if that works.

Yep, that fixed it. Thanks!
The only way to top an upright screen, keyboard, and mouse is to eliminate the need for humans to touch a PC at all. Oh, hello there Mr. Robot... what would I like you to do, you ask?

Offline Webbot

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 2,132
  • Helpful? 108
Re: Trouble with Project Designer makefile for Axon 2
« Reply #3 on: January 23, 2011, 07:36:44 PM »
Yep, that fixed it. Thanks!

ok great. New Project Designer release stops all of this from happening (its an artifact of the up-n-coming version 2)
Webbot Home: http://webbot.org.uk/
WebbotLib online docs: http://webbot.org.uk/WebbotLibDocs
If your in the neighbourhood: http://www.hovinghamspa.co.uk

 


Get Your Ad Here

data_list