go_away

Author Topic: CP102 USB fried - what else might be damaged?  (Read 1128 times)

0 Members and 1 Guest are viewing this topic.

Offline dwmeerTopic starter

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
CP102 USB fried - what else might be damaged?
« on: February 05, 2011, 12:06:13 PM »
I have been using the Axon as a data collection system for my son's science fair project.  Unfortunately this morning he plugged the battery into the 3.3V output port, which fried the USB connection.  I have a programmer, so I was able to reprogram the Axon.  I have made several attempts to use one of the other serial ports for output at several different baud rates from 2400 - 38400.  Unfortunately, I only get gibberish out of hyperterminal.  I have already tried adjusting the baud rate on hyperterminal without success (to values other than that configure for the Axon).  I have tried this through a Prolific USB to serial converter on several computers as well as directly to the serial port on an old Windows 98 laptop with the same results.  The serial output is repeatable, just not decipherable.   

When the power was applied to the 3.3 V pins, what else could have been damaged?

Is it possible to get the CP102 chip replaced, or am I SOL?

Any ideas on how to get some serial communication working so that I can pull data off the Axon?

Thanks,

-Dave

Offline kl22

  • Full Member
  • ***
  • Posts: 104
  • Helpful? 2
Re: CP102 USB fried - what else might be damaged?
« Reply #1 on: April 11, 2011, 11:43:17 PM »
Hi,

Some thought:
I'm not 100% sure, but I'm not fully convinced that you can use the Prolific USB to serial converter. You will need something that does UART to USB.

I'm guessing this is your problem. I've used the other UARTs on the Axon other than the UART1 (usb) and as long as I set hyperterminal/putty to use the exact same baud as I configured in the program it works fine. I think your problem must be the Prolific USB to serial.

(don't quote me on this :D)
« Last Edit: April 12, 2011, 12:01:52 AM by kl22 »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,632
  • Helpful? 169
    • Society of Robots
Re: CP102 USB fried - what else might be damaged?
« Reply #2 on: April 13, 2011, 08:21:02 PM »
I'm with kl22 in not being sure if the Prolific will work. It says 'serial', but it looks like the RS-232 type and not the TTL type.

I'd recommend trying a different adapter:
http://www.sparkfun.com/products/718

I'm pretty sure only the CP2102 is fried, and maybe the Rx and Tx pins just for UART1. Good chance everything else survived.

Offline kl22

  • Full Member
  • ***
  • Posts: 104
  • Helpful? 2
Re: CP102 USB fried - what else might be damaged?
« Reply #3 on: April 14, 2011, 02:13:52 AM »
As Admin mentioned, it should only be CP2102 and maybe UART1.

I just went through the exact same problem. So I can confirm that plugging source into the 3.3V out (exactly what I did) will only fry the CP2102, all other UARTs work fine. If you check the software section of the forum, the admin posted a bootloader that you can flash using a programmer that will use UART0. I used AVR Pocket Programmer, but I believe any ISP programmer will work.

http://www.societyofrobots.com/robotforum/index.php?topic=13628.0

 


Get Your Ad Here