go_away

Author Topic: $50 robot - connecting servos and sensors  (Read 675 times)

0 Members and 1 Guest are viewing this topic.

Offline TheDarkLordTopic starter

  • Jr. Member
  • **
  • Posts: 46
  • Helpful? 0
$50 robot - connecting servos and sensors
« on: June 17, 2011, 10:30:45 AM »
I've just begun building the $50 robot, and have a few questions regarding connecting the servos and sensors to the perf board.

Does it matter which servo (either the one rotating the left wheel, or the right wheel) is connected to one of the pins PD0 and PD1? Similarly, does it matter whether which photoresistor connects with which ADC pin of the microcontroller? I'm pretty new to robotics and programming, so any help would be greatly appreciated.

Thanks in advance,
Vignesh.

Offline newInRobotics

  • Supreme Robot
  • *****
  • Posts: 1,015
  • Helpful? 48
  • N.I.R.
Re: $50 robot - connecting servos and sensors
« Reply #1 on: June 17, 2011, 10:58:23 AM »
It does not matter as long as You change Your code accordingly.
"Computer games don't affect kids; I mean if Pac-Man affected us as kids, we'd all be running around in darkened rooms, munching magic pills and listening to repetitive electronic music." - Kristian W

Offline Conscripted

  • Robot Overlord
  • ****
  • Posts: 291
  • Helpful? 10
Re: $50 robot - connecting servos and sensors
« Reply #2 on: June 17, 2011, 11:09:00 AM »
Good afternoon,

It sounds like your project might be comming along nicely. For the photoresistors it does not matter in the slightest. The servo's do matter. If after connect them you feel that your bot is going backwards then switch the wires. You can of course do as newInRobotics suggested and change the code.

Make sure you post some pics of  your completed robot so we can see.

Conscripted.

 


Get Your Ad Here