go_away

Author Topic: Trouble Connecting AVRISP mkII Programmer to Servo Motor  (Read 1429 times)

0 Members and 1 Guest are viewing this topic.

Offline KirstyTopic starter

  • Beginner
  • *
  • Posts: 4
  • Helpful? 0
Trouble Connecting AVRISP mkII Programmer to Servo Motor
« on: July 26, 2011, 01:08:59 PM »
Hello All,

As you may have picked up from the title of this post I am new to the world of robotics. I am trying my hand at the $50 Robot. I've bought all the bits, installed the stuff for my microcontroller, and managed (I think) to get the .hex file to upload onto the microcontroller program ok. However, I can't physically connect the servo motor to the microcontroller to pass the hex file on and zero my servo motor.

I'm having trouble connecting the servo motor to the microcontroller as the male connection pins have one long side and one short side. I think both parts need a long side in order to be connected up (?) Have I missed buying the correct part? or do I need to start making some circuitry in order to connect these two items? 

Also, the microcontroller has 6 connection points, two rows of 3, does it matter which 3 i connect to?

and lastly, microcontroller has a red bit of wire on one side. servo motor has yellow, red and black wires (red in the middle) so does it matter which side the red bit from the microcontroller is connected to?

Dunno if it makes any difference, but, I am in Britain.

Here is a picture of what I have:



These are the parts I bought:

AVR ISP2 Programmer   
http://www.rapidonline.com/Electronic-Components/Integrated-Circuits/Atmel-Microcontrollers/AVR-ISP-In-system-programmer-Mk2/77826/kw/avrisp+mk2

hi-tec hs-311 servo
http://www.modelmaniacsonline.co.uk/products.php?CatID=12&SubCatID=296&ProductID=1185&Title=Hitec+HS-311&ManCode=HS311

36 position breakaway male header
http://www.rapidonline.com/Cables-Connectors/Connectors-Multipole/PCB-Interconnect/2.54mm-PCB-Interconnection-system/63793/kw/22-0545

hmm... i think thats everything.
Thanks you in advance to anyone who can shed some light.

Kirsty

Offline KirstyTopic starter

  • Beginner
  • *
  • Posts: 4
  • Helpful? 0
Re: Trouble Connecting AVRISP mkII Programmer to Servo Motor
« Reply #1 on: July 26, 2011, 01:13:31 PM »
ok, so the photo didn't work. I'll try this.


Offline KirstyTopic starter

  • Beginner
  • *
  • Posts: 4
  • Helpful? 0
Re: Trouble Connecting AVRISP mkII Programmer to Servo Motor
« Reply #2 on: July 26, 2011, 01:17:50 PM »

Offline richiereynolds

  • Full Member
  • ***
  • Posts: 112
  • Helpful? 3
Re: Trouble Connecting AVRISP mkII Programmer to Servo Motor
« Reply #3 on: July 26, 2011, 04:43:55 PM »
I'm a bit confused by your question, you don't connect the AVRISP to the servo, you connect the AVRISP to the ICSP header and program your microcontroller with it. Then you connect your servo to the male headers you've soldered onto your board, I think maybe you're asking about the male headers?
You solder the short ends to the board and the servo female connector slips onto the longer ends. Have you made the circuit board? You need to do that first.

Offline KirstyTopic starter

  • Beginner
  • *
  • Posts: 4
  • Helpful? 0
Re: Trouble Connecting AVRISP mkII Programmer to Servo Motor
« Reply #4 on: July 27, 2011, 05:36:35 AM »
Thanks Richie!

 


Get Your Ad Here

data_list