Author Topic: Wiring of VNH3SP30 motor driver for Webbotlib control  (Read 827 times)

0 Members and 1 Guest are viewing this topic.

Offline GertlexTopic starter

  • Supreme Robot
  • *****
  • Posts: 744
  • Helpful? 23
  • Nuclear Engineer Roboticist
Wiring of VNH3SP30 motor driver for Webbotlib control
« on: September 14, 2011, 08:35:32 PM »
I've got this motor driver: http://www.pololu.com/catalog/product/707

This is not explicitly supported by Webbotlib, but it seems to be a standard PWM motor driver.  Thus, I anticipate using the "Generic PWM motor driver" ( http://webbot.org.uk/WebbotLibDocs/27520.html ).  I'll use a 3-pin approach since I have plenty of pins free on my Axon and/or Axon Mote...

But which pins on the motor controller am I wiring to?
-The Webbotlib documentation lists these pins as Enable, Input1, Input2.
-Project Designer lists the 3 pins as PWM, Input1, Input2.
-The dual motor driver has Diagnostics/Enable, InputA, InputB, PWM (Pic of pins)

The input pins are prolly A->1 and B->2 (and if not right, I just reverse wires or invert in code).  My question is whether I want the enable pin or PWM pin on the motor driver. I'm assuming PWM pin... this also might just be a case of clarifying in the documentation. Edit2: Got my test set up with Axon, and indeed the PWM pin is the one I want.

Edit: a second question (definitely @ Webbot this time)... I'm trying to add the generic motor driver to the Axon Mote* in Project Designer.  For the supply logic source, I'm not given any options, even though my power supply to the Mote is 5V regulated.  How do I get around this, or is it a bug in Project Designer?  The 5V rails on the Axon and Axon 2 both show up if I do a project with those...  See attached pic of Mote case.

*I understand that the Mote is not officially supported yet, but I got needed files from Admin a month ago and am just getting around to playing with them...
« Last Edit: September 16, 2011, 06:12:19 PM by Gertlex »
I

Offline Webbot

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 2,132
  • Helpful? 109
Re: Wiring of VNH3SP30 motor driver for Webbotlib control
« Reply #1 on: September 20, 2011, 05:52:54 AM »
Looks like you got all the pins figured out.

re Project Designer. The generic PWM motor driver is currently defined to need a +5v regulated supply to feed the logic of the motor controller. The 'issue' with the Mote is that it doesn't have such a supply rail as it works at 3v3. You happen to know that you are using a regulated 5v input as the input to your board but all the Project Designer knows is that it is 5V (ie doesn't know if its regulated or not). Hence the 5v isn't listed in the supply drop down.

I think I'll remove the field from Project Designer since its assuming that the main board needs to supply 5v to the motor controller which, since this is a 'generic' option, may not always be the case (some controllers may use the motor battery input for example or others may only need 3v3). 
Webbot Home: http://webbot.org.uk/
WebbotLib online docs: http://webbot.org.uk/WebbotLibDocs
If your in the neighbourhood: http://www.hovinghamspa.co.uk

Offline GertlexTopic starter

  • Supreme Robot
  • *****
  • Posts: 744
  • Helpful? 23
  • Nuclear Engineer Roboticist
Re: Wiring of VNH3SP30 motor driver for Webbotlib control
« Reply #2 on: September 20, 2011, 07:44:56 AM »
I think I'll remove the field from Project Designer since its assuming that the main board needs to supply 5v to the motor controller which, since this is a 'generic' option, may not always be the case (some controllers may use the motor battery input for example or others may only need 3v3).
That was my hope :) (Or make the option more flexible, allowing for a 5V power supply to be defined as a battery source, and use that...)
I

 


Get Your Ad Here

data_list