Author Topic: Axon Flowstone  (Read 536 times)

0 Members and 1 Guest are viewing this topic.

Offline wecool44Topic starter

  • Jr. Member
  • **
  • Posts: 9
  • Helpful? 0
Axon Flowstone
« on: January 07, 2012, 09:45:13 PM »
I recently installed the new FlowStone 2 demo, and I want to use this with my Axon 1 mcu. I wrote code to send the button state on the axon over uart1, and my axon is connected to COM3. When I run the program on FlowStone, I get nothing. Here is the axon code:

Code: [Select]
/****************************************************************************
*
*   Copyright (c) 2008 [url=http://www.societyofrobots.com]www.societyofrobots.com[/url]
*   (please link back if you use this code!)
*
*   This program is free software; you can redistribute it and/or modify
*   it under the terms of the GNU General Public License version 2 as
*   published by the Free Software Foundation.
*
*   Alternatively, this software may be distributed under the terms of BSD
*   license.
*
****************************************************************************/

//Add your code here
#include <avr/delay.h>
//enter your code in control here
//photovore is just a default sample program and can be deleted
void control(void) {
int buttonpressed;
while(1) {
buttonpressed = button_pressed();
uart1SendByte(buttonpressed);
_delay_ms(10);
}}

I attached my flowstone file. Please help.

Offline wecool44Topic starter

  • Jr. Member
  • **
  • Posts: 9
  • Helpful? 0
Re: Axon Flowstone
« Reply #1 on: January 10, 2012, 07:16:01 PM »
I wrote a new program for flowstone, and now it tells me that it failed to set configuration for port. My baud rate is set, could anybody give me the correct values for stop bits, parity, etc?

Offline Gertlex

  • Supreme Robot
  • *****
  • Posts: 746
  • Helpful? 23
  • Nuclear Engineer Roboticist
Re: Axon Flowstone
« Reply #2 on: January 10, 2012, 08:14:36 PM »
The correct settings are probably the defaults. I've never run into a case where this wasn't the case (well, besides the baud anyways.)  Beyond that, I've got nothing on your setup.
I

 


Get Your Ad Here