go_away

Author Topic: AVRRISP MKII Connect Failed  (Read 3206 times)

0 Members and 1 Guest are viewing this topic.

Offline mstacho

  • Supreme Robot
  • *****
  • Posts: 375
  • Helpful? 10
Re: AVRRISP MKII Connect Failed
« Reply #30 on: July 06, 2012, 10:53:02 AM »
hm...4.6V should be OK.  Is that pin connected directly to the 5V source?  IF so, then your ISP can't reset it.  Although, if it is ONLY connected to the reset pin of the ISP, it is not your problem at all.

Try to breadboard it.  I'm heading out now, but I'll respond on Sunday if no one else has fixed the problem.  Good luck!

MIKE
Current project: tactile sensing systems for multifingered robot hands

Offline ErikYTopic starter

  • Robot Overlord
  • ****
  • Posts: 186
  • Helpful? 0
Re: AVRRISP MKII Connect Failed
« Reply #31 on: July 06, 2012, 11:04:18 AM »
hm...4.6V should be OK.  Is that pin connected directly to the 5V source?  IF so, then your ISP can't reset it.  Although, if it is ONLY connected to the reset pin of the ISP, it is not your problem at all.

Try to breadboard it.  I'm heading out now, but I'll respond on Sunday if no one else has fixed the problem.  Good luck!

MIKE

Yeah, that is only connected to the programmer reset.

Thx again for all your help, have a good weekend.

Going to try to breadboard it, if anyone else sees anything or has any suggestions I would appreciate any help.

Thx!
Erik

Offline ErikYTopic starter

  • Robot Overlord
  • ****
  • Posts: 186
  • Helpful? 0
Re: AVRRISP MKII Connect Failed
« Reply #32 on: July 06, 2012, 12:31:13 PM »
OK, I FINALLY GOT IT WORKING!

So, I uninstalled everything and installed 4.15 instead.

It worked right away.

It prompted me to update my driver right away, it worked, and then I was able to connect and program my mcu with the modify servo hex file!

On to modifying my servos now.

Thanks so much for everyone who helped!

Really appreciate it!

Offline mstacho

  • Supreme Robot
  • *****
  • Posts: 375
  • Helpful? 10
Re: AVRRISP MKII Connect Failed
« Reply #33 on: July 09, 2012, 08:49:40 AM »
Haha congrats.

MIKE
Current project: tactile sensing systems for multifingered robot hands

Offline ErikYTopic starter

  • Robot Overlord
  • ****
  • Posts: 186
  • Helpful? 0
Re: AVRRISP MKII Connect Failed
« Reply #34 on: July 10, 2012, 04:04:54 AM »
Haha congrats.

MIKE

Thanks Mike!

Thanks for taking the time to help me out, much appreciated.


 


Get Your Ad Here