Author Topic: AVR Plugin for Eclipse Trouble  (Read 1018 times)

0 Members and 1 Guest are viewing this topic.

Offline greywanderer012345Topic starter

  • Robot Overlord
  • ****
  • Posts: 133
  • Helpful? 2
AVR Plugin for Eclipse Trouble
« on: August 16, 2012, 10:36:35 PM »
I have everything installed properly as far as I can tell, but I get this error in the console when I try to build my project.


make all
Building file: ../main.c
Invoking: AVR Compiler
make: write error
make: write error: No such file or directory
make: write error: No such file or directory
make: write error: No such file or directory
make: write error: No such file or directory
make: write error: No such file or directory
make: write error: No such file or directory

I have WinAVR installed and AVRGcc was selectable toolchain when I started this project. I am able to use AVRStudio perfectly fine, so I'm sure I have an incorrect setting in Eclipse. can anyone help me out? Thanks.

Offline greywanderer012345Topic starter

  • Robot Overlord
  • ****
  • Posts: 133
  • Helpful? 2
Re: AVR Plugin for Eclipse Trouble
« Reply #1 on: August 16, 2012, 11:50:57 PM »
actually, restarting my entire system got the project to build. Now I am having trouble setting up the debugger, and I'm starting to wonder if I should even debug in eclipse at all. My current problem is that my version of simulavr does not support the atmega328. What I would really like to do is create and edit my project with eclipse, but use the avrstudio debugger. Does anyone have any suggestions?

 


Get Your Ad Here