Mechanics and Construction > Mechanics and Construction

50 $ Robot


Been at this for quite awhile figuring stuff out. At the moment I feel a bit lost.
(bare with me I'm new with this)

I have all the components soldered onto the board and wired except the power source (batteries). Right now I'm a bit confused by the pictures/schematics vs what mine looks like. I mainly followed schematic, but this looks different then the pictures on the tutorial (even when he used a batterholder at the end).

I'm feeling unsure I am doing this correctly and would love some feedback before I proceed.
So (after testing) all I have to do is solder the battery holder in the servo circut and the 9v battery in the microcontroller circut?

Other things:

I don't fully understand the resistance test. I set my multimeter to ohms with the correct range but it always showed up as 0 no matter where I set the needles.

I used thicker gauge wire than I probably should have used.
I started with 14 gauge as that was the smallest wire available at the hardware store, but later ordered 22 gauge mid-project (still big). Will this have any effect on the robot?

Either wire size will work. Just ensue that any place the insulated wire crosses another wire they are not shorted together (should measure infinite Ohms). You might find smaller wire inside old electronics that is being thrown away (as well as other usable parts).

Is your meter digital?
What does it read when the two probes are touched together verse when they are not touching?
Maybe some pictures so we can be sure of what you are seeing.
Try measuring across the resistor (or a spare) on your board. You should be able to measure its value.

The build of the board looks pretty good. Once you understand how to use the Ohmmeter check that there are no short circuits between all pins on the processor socket that shouldn't be connected.
Next is to apply power to the regulator (with out the processor installed) and check the regulators output voltage and the voltage on the socket pins.

Sorry for (really) late reply. I really hate asking questions and prefer to figure stuff out through forums ect.

Okay. The issue was a wiring problem. I fixed it and now all non-connecting wiring has around 30 Mohm resistance. All connected has 0.
(My multimeter is a needlessly expensive Klein Tool MM1000 btw.)

After wiring batteries, I am having trouble uploading the code to the processor. I did it once successfully (or so I think) by using a particular command code I found on another post (using avrdude on command prompt - Windows XP), but since then I have had no luck leading me to think there is an issue with my processor.

I have the pocketavr programmer and atmega8. AVRStudio does not see the processor. AVRdude worked one time (so i think) but then I can't seem to get it right now.

avrdude -c usbtiny -B 1 -patmega8 -U flash:w:main.hex
initialization failed, rc=-1
Double check connections and try again....

Yes I used -F before.
Device signature = 0x000000
Invalid signature

Photoresistors are soldered on, servos are modified. Servos work, but only turn till it stops, and the modified one seems to just jerk when i turn on the power. When i cover up the photoresistors nothing happens (because that's what the robot is designed to do correct? move according to light?). So I'm just confused.

 (I found atmegas for almost a buck with free shipping on ebay. Does anyone use ebay? Its a lot cheaper than digikey.)

Oh, and LED light doesn't turn on.

I followed the guide, the longer led is closer to DEP socket. Another post stated that the writer made a mistake and the longer led needs to be away from DEP socket.

If its the code I replaced the "LED_off();//turn LED on" to "LED_on();//turn LED on" on hex code (but have not been able to upload the new code to my processor).

Finally, I suppose it could be burnt out..


[0] Message Index

Go to full version