Software > Software

help regarding errors in avr studio 4

(1/2) > >>

dv.phaneeswar:
hey can any one help me by telling the meaning of this error

make: *** No rule to make target `../../SOURCE', needed by `vrbot4.elf'.  Stop.

Build failed with 1 errors and 0 warnings...

the code (for vrbot) it just executed with 0 errors but when i press the Rebuilt it is showing this error (in avr studio 4)
i just did the project (controlling the srevos using voice commands) in webbotlib project designer and added the vr_library.h in the project folder and changed the program according to the voice recognition sample code available in the site.

dv.phaneeswar:
opt_TimerOverflow.o:(.data+0x0): multiple definition of `cpu_speed'
opt_TimerCompare.o:(.data+0x0): first defined here
opt_TimerOverflow.o:(.data+0x4): multiple definition of `cpu_speed_div_1000'
opt_TimerCompare.o:(.data+0x4): first defined here
opt_TimerOverflow.o:(.data+0x6): multiple definition of `cpu_speed_div_1000000'
opt_TimerCompare.o:(.data+0x6): first defined here
lib_hardware.o:(.data+0x0): multiple definition of `cpu_speed'
opt_TimerCompare.o:(.data+0x0): first defined here
lib_hardware.o:(.data+0x4): multiple definition of `cpu_speed_div_1000'
opt_TimerCompare.o:(.data+0x4): first defined here
lib_hardware.o:(.data+0x6): multiple definition of `cpu_speed_div_1000000'
opt_TimerCompare.o:(.data+0x6): first defined here
opt_TimerCapture.o:(.data+0x0): multiple definition of `cpu_speed'
opt_TimerCompare.o:(.data+0x0): first defined here
opt_TimerCapture.o:(.data+0x4): multiple definition of `cpu_speed_div_1000'
opt_TimerCompare.o:(.data+0x4): first defined here
opt_TimerCapture.o:(.data+0x6): multiple definition of `cpu_speed_div_1000000'
opt_TimerCompare.o:(.data+0x6): first defined here
make: *** [vrbot4.elf] Error 1
Build failed with 1 errors and 0 warnings...




this is the error which i got by rebuilting after unclicking " Use External Makefile "  and choosing the other alternative in general configuration options......
please someone help me in solving this error, i have been strucked in sloving this for last 3 weeks....

thanks in advance....

Admin:
The errors you are getting are because you didn't correctly follow instructions for WebbotLib :P

Follow this exactly, without modification:
http://www.societyofrobots.com/axon2/axon2_setup1.shtml

And then bit by bit add in your own code, compiling at each step. That way you'll know what step you did was wrong.

dv.phaneeswar:

--- Quote from: Admin on December 21, 2012, 12:15:37 PM ---The errors you are getting are because you didn't correctly follow instructions for WebbotLib :P

Follow this exactly, without modification:
http://www.societyofrobots.com/axon2/axon2_setup1.shtml

And then bit by bit add in your own code, compiling at each step. That way you'll know what step you did was wrong.

--- End quote ---



SIR i did exactly what you said , i reinstalled eveye thing (winavr, avr studio 4.19 ,webbotlib) now i am getting this error




Build started 5.1.2013 at 17:34:56
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT gen_clock.o -MF dep/gen_cl
ock.o.d  -c -Os ../lib/gen_clock.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [gen_clock.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT lib_timers.o -MF dep/lib_t
imers.o.d  -c -Os ../lib/lib_timers.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [lib_timers.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT vrbot.o -MF dep/vrbot.o.d
 -c  ../vrbot.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [vrbot.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT opt_TimerCapture.o -MF dep
/opt_TimerCapture.o.d  -c -Os ../lib/opt_TimerCapture.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [opt_TimerCapture.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT lib_timerdef.o -MF dep/lib
_timerdef.o.d  -c -Os ../lib/lib_timerdef.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [lib_timerdef.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT opt_TimerOverflow.o -MF de
p/opt_TimerOverflow.o.d  -c -Os ../lib/opt_TimerOverflow.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [opt_TimerOverflow.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT lib_hardware.o -MF dep/lib
_hardware.o.d  -c -Os ../lib/lib_hardware.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [lib_hardware.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT opt_pcint.o -MF dep/opt_pc
int.o.d  -c -Os ../lib/opt_pcint.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [opt_pcint.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT opt_TimerCompare.o -MF dep
/opt_TimerCompare.o.d  -c -Os ../lib/opt_TimerCompare.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [opt_TimerCompare.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT opt_DeviceName.o -MF dep/o
pt_DeviceName.o.d  -c -Os ../lib/opt_DeviceName.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [opt_DeviceName.o] Error 127 (ignored)
I"E:\programs\vrbot\..\..\Webbot\source files" -I"E:\programs\vrbot\."  -mmcu=atmega640 -Wall -gdwarf-2 -std=gnu99                -DF_CPU=16000000UL -O0 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT lib_iopins.o -MF dep/lib_i
opins.o.d  -c -Os ../lib/lib_iopins.c

/usr/bin/sh: IE:\programs\vrbot\..\..\Webbot\source files: command not found
make: [lib_iopins.o] Error 127 (ignored)
mmcu=atmega640  gen_clock.o lib_timers.o vrbot.o opt_TimerCapture.o lib_timerdef.o opt_TimerOverflow.o lib_hardware.o opt_pcint.o opt_TimerCompare.o opt_DeviceName.o lib_iopins.o   -L"E:\Webbot\sourcefiles"  -lWebbot-ATmega640 -lm -lc  -o vrbot.elf
/usr/bin/sh: gen_clock.o: command not found
make: [vrbot.elf] Error 127 (ignored)
avr-objcopy -O ihex -R .eeprom -R .fuse -R .lock -R .signature  vrbot.elf vrbot.hex
avr-objcopy: 'vrbot.elf': No such file
make: *** [vrbot.hex] Error 1
Build failed with 1 errors and 0 warnings...


sir please help me in solving this error i have been stuck in the middle for a long time ......

Admin:
Start a new project, and follow the directions exactly. *Do not* add any vrbot code.

Generate the code in Project Designer, then load up AVR Studio and compile. Don't add any code of your own, just follow the tutorial.

Let me know if that works.

Navigation

[0] Message Index

[#] Next page

Go to full version