go_away

Author Topic: iRobot Create with AVR Studio  (Read 3187 times)

0 Members and 1 Guest are viewing this topic.

Offline AdminTopic starter

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
iRobot Create with AVR Studio
« on: July 27, 2007, 06:29:04 PM »
Anyone use the iRobot Create with AVR Studio?

For the life of me I can't get it to connect . . .

The instruction manual is totally useless . . . and AVR Studio is not mentioned in their forum either . . .

(btw, I managed to get a free iRobot Create on the premise that I can put SLAM on it)

Offline gmatty

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
Re: iRobot Create with AVR Studio
« Reply #1 on: May 11, 2011, 11:49:29 AM »
I came across this in a desperate google search to see if anyone else is having basic connectivity problems with the create as well. Sorry if I'm ressurecting a dead thread but I was wondering if you ever resolved this.

I tried following the manual and using their http://realterm.sourceforge.net program, and I attach the create to my pc via a serial port but I get absolutely nothing (no incoming data and any commands I send seem to go into the abyss.)

I seem to manage to get somekind of response by sending the 128 opcode sometimes (the roomba beeps) but thats about it, all the other opcodes are absolutely ignored.

I phoned the irobot tech support and they seemed more than useless, telling me its probably because I am using Windows 7 and I should be using Windows XP  as thats what the Create was designed for... though I fail to see how that would change anything, as a serial port is still just a serial port....


Offline AdminTopic starter

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: iRobot Create with AVR Studio
« Reply #2 on: May 13, 2011, 04:17:42 PM »
Wow thats an old thread . . . and shame on me for not posting the solution!

I really don't remember at all what the problem was, but I do remember it taking days to figure out. I think it was AVR Dude causing me issues . . .

Anyway, here is my writeup on how I program it:
http://www.societyofrobots.com/robot_iRobot_Create_mod.shtml

Offline madsci1016

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 1,450
  • Helpful? 43
Re: iRobot Create with AVR Studio
« Reply #3 on: May 14, 2011, 08:22:11 AM »
I think you guys are talking about two different issues here.

Admin, you were trying to program the create (Command module?) using AVR studio.

gmatty is just trying to talk to a create over it's serial port. Sending Opcodes using a terminal program.



gmatty, try using a create control program like this one to control the create and see if it works. It may be something odd with the terminal program you are using.

 


Get Your Ad Here