2

Author Topic: Power Problems  (Read 760 times)

0 Members and 1 Guest are viewing this topic.

Offline Walter103Topic starter

  • Beginner
  • *
  • Posts: 3
  • Helpful? 0
Power Problems
« on: March 30, 2013, 01:48:38 PM »
Hi there,
     I'm new to robotics and I am having an issue with the electronics aspect of my first robot. Here is a run down on the project.

     I am using lynxmotion tracks and sprockets combined with a custom chassis I made with the help of a local machinist. It is driven by two banebots rs550 motors with 16:1 gearboxes. Power has been supplied by a 11.1volt 15c (20c burst)1200 mAH lithium polymer battery. Although I plan to use an Arduino to control my bot in the future, I am currently just controlling it via an rc transmitter and receiver with a sabertooth 2x12 rc motor controller. The whole thing weighs in at about 12 pounds.

     It runs fine for a short time on a full charge, but after a bit the motors just jerk a little and the error light comes on on the sabertooth. I believe my problem lies either in the battery or the motor controller. Either the battery can't supply enough power, or the motors are pulling to much current for the sabertooth to handle. How much current do the rs550 motors draw? I believe the saber tooth is rated for 12amps...

     Battery? Motor controller? Some other part? I'm just looking for advice from more experienced people!

Thanks!
Walter

Online waltr

  • Supreme Robot
  • *****
  • Posts: 1,929
  • Helpful? 98
Re: Power Problems
« Reply #1 on: March 30, 2013, 03:34:09 PM »
Did you look at the motors specs on Banebot's web site??
Its here:
http://banebots.com/p/M5-RS550-12
The No load current is 1.4A and max current is 85A.

How long does it run from after changing the Batteries??
If 10minute (1/6 hour) and with a 1.2A-Hr battery means that the motors are drawing about 7.2Amp which is well within the Banebot spec. These motors can draw much, much more current than this.

Have you measured the actual current draw of the motors?
Do this then divide the battery's capacity by the average motor current to find the number of run hours expected.

The Sabertooth has these specs:
Quote
Out of the box, the Sabertooth can supply two DC brushed motors with up to 5A each continuously. Peak currents of 10A are achievable for short periods. Because Sabertooth 2x5 incorporates soft current limiting and thermal protection, you need not worry about killing the driver with accidental stalls or by hooking up too big a motor.

So the Banebot motors can draw much more than the Sabetooth will allow. It will of course either current limit so you should not hurt the Sabertooth.

Have you read the Sabertooth manuals? It says about the error light this:
Quote
The red LED illuminates if the Sabertooth has
detected a problem. It will light if the driver has
shut down due to a depleted battery or due to overheating or overcurrent. If you are using a NiCd
or NiMH battery, and commanding an acceleration causes the motor to jerk and the Error LED to
flash on and off, the battery is depleted.


And from my above calculations it seems to be the battery is depleted.
What is the battery Voltage when the error light comes on??

Offline jwatte

  • Supreme Robot
  • *****
  • Posts: 1,343
  • Helpful? 81
Re: Power Problems
« Reply #2 on: March 30, 2013, 11:02:21 PM »
1100 mAh an 12 pounds is nowhere near a good match. I'm using 10 Ah (10000 mAh) for a similarly weighted robot with significantly weaker motors (stall current about 6A.)

Offline Walter103Topic starter

  • Beginner
  • *
  • Posts: 3
  • Helpful? 0
Re: Power Problems
« Reply #3 on: March 31, 2013, 09:56:07 PM »
Thanks for the replys! I ran my battery so low on my last test it wouldn't charge. I used a NIHM charger to bring all the cells back up to the point where the lipo charger would recognize them. I didn't have time to fully charge the battery but I ran a test with it partially charged. It ran alright but still jolted around and triggered
The error light. When I finished the battery had a perfectly normal of about 12.45. I haven't ever been able to get it up to full throttle for any amount of time even on a full charge. This makes me think that the motors are drawing more current than the sabertooth can handle. However it seems that the error light comes on more as I drain the battery. Could my problem be a combination of both a puny battery and an undersized motor controller? Also I am using the sabertooth 2x12 not the 2x5.
Thanks
 Walter

Edit: Tested on a full charge yesterday. Even with a full battery I couldn't get far past halve throttle before the error light came on. However, it runs fine at less than quarter throttle just very, very slowly. This makes me think I need a larger motor control. Any suggestions?
 It ran for about 15 mins at a snail's pace, and when I finished the battery voltage was as follows.
Cell 1: 3.79 V
Cell 2: 7.59
Cell 3: 11.25
Whole battery:11.25
« Last Edit: April 02, 2013, 10:45:33 AM by Walter103 »

Online waltr

  • Supreme Robot
  • *****
  • Posts: 1,929
  • Helpful? 98
Re: Power Problems
« Reply #4 on: April 02, 2013, 06:02:44 PM »
The error light can come on "due to a depleted battery or due to overheating or overcurrent" as stated in the Sabertooth manual.

With the battery you are using it very well could be that there is a significant voltage drop in the battery or battery leads that the Sabertooth detects as an "under voltage" (depleted battery).

What is the Battery Voltage At the Sabertooth while running the motors at 1/4, 1/2 & full speed?
If the Voltage is above the Sabertooth's detection threshold (see manual) then the error is very likely to be an "Overcurrent" detection.
However, there still could be a very short time UnderVoltage that a Voltmeter will not see since the meter averages.

If the three Cells in your battery pack are that much different then you have other problems.
What are each Cell's voltage 30 minutes after fully charging. If the three cells still have that much of a voltage difference then you need to equalize the cells ASAP or else that battery pack will be permanently damaged.

Oh,,,,wait a minute:::: You measure from one end of the battery pack to each of the three cells. That would make the cell Voltages:
cell 1 = 3.79V
cell 2 = 3.80V
cell 3 = 3.66V
The third cell is a bit weaker than the other two and the pack should still be equalized.
Also, these Voltages indicate that the Battery still has a goo amount of charge left so my guess that there is a substantial Voltage drop in the battery or leads is very possible.

How heavy are the battery to Sabertooth wires?
Make sure these are at least 14 gauge or larger.

Next is getting a much larger battery pack as jwatt suggested.
« Last Edit: April 02, 2013, 06:12:57 PM by waltr »

Offline Walter103Topic starter

  • Beginner
  • *
  • Posts: 3
  • Helpful? 0
Re: Power Problems
« Reply #5 on: April 03, 2013, 07:38:51 PM »
The battery is definatly the major problem. I changed the plug on the saber tooth and tried a 1600 mah battery and it ran much better. I am planning to buy a 5000mah battery, but I don't know what discharge rate to get. What do you think the 2x12 saber tooth can handle? I am also considering putting two batteries in parralell to increase capacity.

Thanks

Walter

Edit: Although I guess the motors will only draw the current they need. So it can't hurt to get a battery with a high discharge rate. Right?
« Last Edit: April 03, 2013, 07:48:54 PM by Walter103 »

Online waltr

  • Supreme Robot
  • *****
  • Posts: 1,929
  • Helpful? 98
Re: Power Problems
« Reply #6 on: April 03, 2013, 08:58:21 PM »
The Sabertooth 2x12 is only 12A continuous and 15A for no more than a few seconds. Still could be under sized for those BaneBot motors (max current is 85A).

A much large battery is desired in either case.
Quote
So it can't hurt to get a battery with a high discharge rate. Right?
Correct. Also a battery with heave wire leads will help.

Did you measure the actual current draw of the motor as I suggested? This will tell you which motor controller and battery to use. With out this information you are just guessing what might work correctly.

 


Get Your Ad Here