Author Topic: AVR studio programming for $50 robot  (Read 726 times)

0 Members and 1 Guest are viewing this topic.

Offline jlam456Topic starter

  • Beginner
  • *
  • Posts: 3
  • Helpful? 0
AVR studio programming for $50 robot
« on: April 02, 2013, 08:20:28 PM »
hi im new to robotics. i literally have no idea what im doing. but i decided to try out the $50 robot. when i tried programming it through AVR Studio 4  i ran into some problems. im using the AVRISP MKII programmer with and ATmega8. when i tried inputting a hex file i get this message
Reading FLASH input file.. OK
Setting mode and device parameters.. OK!
Entering programming mode.. FAILED!
Leaving programming mode.. OK!
any body know what i could do to get this robot working. i tried lowering the ISP frequency but still no luck...

Offline Please_Denise

  • Beginner
  • *
  • Posts: 5
  • Helpful? 0
Re: AVR studio programming for $50 robot
« Reply #1 on: May 06, 2013, 06:13:18 AM »
- Be sure to erase the device before you load a different program into the micro-controller

- Make sure your 9v battery is full and properly soldered

I used to have this exact same problem and it took me 2 days to figure it out. I just got myself a new 9v alkaline battery as the rechargeable battery I was using was empty upon delivery and I didn't have a charger at the time. Boom - everything worked.

However, I understand there could be multiple factors involved. Prior to the battery problem, I had multiple short circuits at the programmer header due to my messy soldering. Post a picture of your circuit from underneath where the soldering was done. Try to use Macro settings on your digital camera . . if you own one . . and take pictures from different angles.

Debugging can be very frustrating but in my experience it helps to use the 'elimination method' which goes something like this:

- Is the Battery out? Let's unplug the battery and try that again. See what changes and what doesn't.
- Is this ground cable broken? Let's unsolder it. See what changes and what doesn't.

I managed to build the robot alright. I just screwed up the LED - and one of the servos is wearing out, often running slower than the other one, then all of the sudden speeding up. Really frustrating, but it's a great learning experience. That's the whole point of the journey - Not just so you can follow the instructions and be Done with it.

 


Get Your Ad Here

data_list