Author Topic: force sensing resistor  (Read 1140 times)

0 Members and 1 Guest are viewing this topic.

Offline al-ghazaliTopic starter

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
force sensing resistor
« on: April 29, 2013, 08:43:18 PM »
please help me .....i'm doing exoskeletons project using force sensing resistor (FSR) sensor for detecting elbow..but it seems that i could not get the reading from the sensor when im attach to the elbow.....what should I do???????

Offline newInRobotics

  • Supreme Robot
  • *****
  • Posts: 1,015
  • Helpful? 48
  • N.I.R.
Re: force sensing resistor
« Reply #1 on: April 30, 2013, 12:33:40 AM »
What You've written is very vague. You have to describe the exact set-up You use, or better, post circuit diagram, only then we are going to able to at least have a shot at it  :)

From what You wrote now, I understand that You took FSR, sellotaped it to an elbow and hoped to get a reading in some magic way :)
"Computer games don't affect kids; I mean if Pac-Man affected us as kids, we'd all be running around in darkened rooms, munching magic pills and listening to repetitive electronic music." - Kristian W

Offline jkerns

  • Robot Overlord
  • ****
  • Posts: 270
  • Helpful? 12
Re: force sensing resistor
« Reply #2 on: April 30, 2013, 07:20:26 AM »
Is the problem mechanical - the force is not properly applied to the device?
electrical - your interface circuitry is not working?
or software - you are not reading the A/D properly?

You say it didn't work when you connected it to the elbow. Did it work before you connected it? Did you test it before you connected it?

What changed between when it worked and when it didn't work? There is a big difference between solving a "never worked" and "stopped working" problem.

If you connect your A/D to a simple voltage source, can you read the voltage?

Do you see a voltage at the A/D pin with the resistor and interface ciruit connected?

When you say you cannot get a reading - what does that mean? You don't get a value from the A/D? You get a value but it doesn't change when you apply a force?

What kind of testing / debugging have you done so far?
I get paid to play with robots - can't beat that with a stick.


Get Your Ad Here