go_away

Author Topic: Arduino SRF08 rangefinder and servomotor problem  (Read 786 times)

0 Members and 1 Guest are viewing this topic.

Offline syastwTopic starter

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
Arduino SRF08 rangefinder and servomotor problem
« on: May 04, 2013, 12:24:05 PM »
Hello,


I'm new to the forum, I'm not sure this is the right place to ask for help, but I'll give it a go.

I'm trying to build an arduino robot with servos and a range finder.

I ran into problems when connecting SRF08 rangefinder and HS-434BB servo motor to the arduino.

If the servo is connected when the arduino is booted, rangefinder cannot find its first range.

If the servo is not connected when arduino is booted rangefinder starts to find ranges and if servo is then connected both work fine at the same time for a while and then suddenly stop. Curious is that if I then boot the arduino, they often start working even though servo was connected.

As attachments there is a picture of the electronics and the source code.


Thanks for reading!

Offline jkerns

  • Robot Overlord
  • ****
  • Posts: 265
  • Helpful? 12
Re: Arduino SRF08 rangefinder and servomotor problem
« Reply #1 on: May 04, 2013, 01:16:11 PM »
How much current does the servo draw and how much current can the Arduino regulated power supply provide?
I get paid to play with robots - can't beat that with a stick.

http://www.ltu.edu/engineering/mechanical/bachelor-science-robotics-engineering.asp

Offline jwatte

  • Supreme Robot
  • *****
  • Posts: 1,343
  • Helpful? 81
Re: Arduino SRF08 rangefinder and servomotor problem
« Reply #2 on: May 05, 2013, 09:01:20 PM »
Do not power a servo directly from the 5V out of the Arduino; it is not capable to provide enough current.

Tyipcally, you will power the servo directly from the input power of the Arduino (the Vin pin.) If that is higher than the servo can handle, then use a separate regulator to provide the right voltage to the servo..


 


Get Your Ad Here

data_list