go_away

Author Topic: Need Help With AVR mkii  (Read 414 times)

0 Members and 1 Guest are viewing this topic.

Offline AheaTopic starter

  • Beginner
  • *
  • Posts: 2
  • Helpful? 0
Need Help With AVR mkii
« on: May 09, 2013, 03:41:55 PM »
I recently picked up a avr mkii to start programming avr micros in c. I have had an Adafruit BoArduino the usb version for awhile so I tried using the isp headers on the board to try programming an atmega328. When I attach the mkii to the headers the mkii light blinks orange, I have looked over the solder joints to check if any are bad and they look fine. I know that the orange blinking light means that the circuit is supposed to be bad. So I wired the an atmega on a breadboard to see if it was the BoArduino giving me the issue, and I still got the blinking orange light, I believe that I did hook everything up correctly I checked many times to insure that I did. Also it start blinking after i connect power to the atmega and it is red before I connect the power. What could be causing me this problem? Could the mkii be broken? I am not sure what to do from here to see if it is the mkii. I can take pictures of how I wired everything up on a breadboard if that would help.

Offline jkerns

  • Robot Overlord
  • ****
  • Posts: 251
  • Helpful? 12
Re: Need Help With AVR mkii
« Reply #1 on: May 09, 2013, 06:16:38 PM »
One thing that can happen is that software already running on the AVR chip can be using one of the pins as an output and is pulling it high.

The light should be red when the programmer is connected and there is no power at the ISP header pins.
I get paid to play with robots - can't beat that with a stick.

http://www.ltu.edu/engineering/mechanical/bachelor-science-robotics-engineering.asp

Offline AheaTopic starter

  • Beginner
  • *
  • Posts: 2
  • Helpful? 0
Re: Need Help With AVR mkii
« Reply #2 on: May 10, 2013, 01:46:34 PM »
The chip I am using is new, so there is not any software running on the chip, also I know that the red light should come on when i connect the mkii to the isp header, but when i connect the 5v power supply is when I get the orange blinking light.

 


Get Your Ad Here

data_list