Author Topic: Beaglebone robot can't go in reverse  (Read 604 times)

0 Members and 1 Guest are viewing this topic.

Offline saintjonTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Beaglebone robot can't go in reverse
« on: July 15, 2013, 05:01:57 PM »
I have a power regulator that provides 2 outputs.  One is 7.2v and the other is about 5v.  On the 5v is the Beaglebone Black. I know how to take a HIGH signal into an H bridge to tell my bot to move forward but how do I tell it to move in reverse?  I assume that there is a way to send a signal to activate reverse motion?

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,941
  • Helpful? 98
Re: Beaglebone robot can't go in reverse
« Reply #1 on: July 15, 2013, 05:22:16 PM »
Which H-bridge circuit? Link to data sheet or schematic please.

There should be Enable and Phase inputs or other inputs that allows turning on any leg of the H-bridge. When one side-upper and the opposite side bottom is on then the motor turns in one direction. When these are flipper, first side bottom and opposite side top is on then the motor turns in the other direction.

Google H-bridge to learn how it works.

Offline saintjonTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Re: Beaglebone robot can't go in reverse
« Reply #2 on: July 15, 2013, 06:26:08 PM »

Offline saintjonTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Re: Beaglebone robot can't go in reverse
« Reply #3 on: July 15, 2013, 06:28:11 PM »
Never mind.  I misread.  Noob mistake....

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,941
  • Helpful? 98
Re: Beaglebone robot can't go in reverse
« Reply #4 on: July 15, 2013, 09:28:25 PM »
Ok. Sounds like you are learning. Keep at it.

 


Get Your Ad Here