Author Topic: Issue with stk500v2 programmer drivers  (Read 630 times)

0 Members and 1 Guest are viewing this topic.

Offline yashmaniacTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Issue with stk500v2 programmer drivers
« on: December 07, 2013, 09:58:33 AM »
Hi,
  This is my first post here. I have been using this programmer (STK500V2 equivalent)  for quite some time now with Windows xp, and it never gave me trouble. But since I upgraded to Windows 7 64 bit, I have been able to install the drivers for this programmer, but have been unable to get WinAVR to open its serial port. I've tried switching COM ports, but nothing works. I would really appreciate it if anyone could help me out with this,
thanks in advance

link: http://nex-robotics.com/index.php?page=shop.product_details&flypage=flypage.tpl&product_id=810&category_id=7&option=com_virtuemart&Itemid=45

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,936
  • Helpful? 98
Re: Issue with stk500v2 programmer drivers
« Reply #1 on: December 07, 2013, 10:56:51 AM »
Is the programmer showing up in Device Manager?
And if so is the name, status and driver correct?

I've had problems with Win 7, 8, 8.1 in both 32 & 64bit where Windows replaces the driver drive for USB to Serial chips to some latest driver that doesn't work with an older chip (in particular the older Prolific chips).

If this is the case then there are steps to take to keep windows from using the wrong driver.

Offline yashmaniacTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Re: Issue with stk500v2 programmer drivers
« Reply #2 on: December 07, 2013, 11:08:10 AM »
The name shows up correctly...status also shows that device driver works properly. The only time I face an issue is when I try to upload a program through WinAVR. And I installed the drivers that came with the programmer. So if Windows replaced my drivers, how do I fix that??

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,936
  • Helpful? 98
Re: Issue with stk500v2 programmer drivers
« Reply #3 on: December 07, 2013, 02:54:42 PM »
Quote
The name shows up correctly...status also shows that device driver works properly.
If this is so and the drive Date is the same as the one you install then there is a different issue.

Since I don't use that programmer I can't check what else could be the issue.
It could be a 'windows permissions' or a compatibility issue. Things to try are running the programming software as an administrator, and trying to run the software in XP compatibility mode.

Did you do a web search, try different search terms, to see if anyone else has seen this and has a solution?

Else, lets hop[e some one else on this forum knows what to fix is.

Offline yashmaniacTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Re: Issue with stk500v2 programmer drivers
« Reply #4 on: December 07, 2013, 07:35:58 PM »
Just saw, that the driver install date shown is 6/6/2006...also, the driver is not digitally signed. So I'm guessing its a permissions issue....

Offline yashmaniacTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Re: Issue with stk500v2 programmer drivers
« Reply #5 on: December 08, 2013, 07:54:05 PM »
Thanks man...signing the drivers worked. I see there is a helpful tag here. How do I mark your post as helpful??

Offline waltr

  • Supreme Robot
  • *****
  • Posts: 1,936
  • Helpful? 98
Re: Issue with stk500v2 programmer drivers
« Reply #6 on: December 09, 2013, 08:04:04 AM »
Ok, good you got it working even if my suggestions didn't help.
Cheers

 


Get Your Ad Here