Author Topic: AVRISP mk II - no robot detected  (Read 1497 times)

0 Members and 1 Guest are viewing this topic.

Offline StKildaTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
AVRISP mk II - no robot detected
« on: May 10, 2014, 11:40:03 AM »
So I am building the $50 robot.  Circuit board is built and the connectivity using a meter seems ok.  I connect up the Atmel AVRISP mk II via usb and the lights on the usb unit come on.  Using AVR Studio 4 (4.13) I get "Connect failed - select AVR programmer" - I'm selecting the "platform" as AVRISP mk II and the port as USB - but still no connection.

I'm not sure if it is the connection between the PC and the AVRISP - or if my robot board is not functioning correctly.

Any suggestions please.

Thanks

Offline jkerns

  • Robot Overlord
  • ****
  • Posts: 270
  • Helpful? 12
Re: AVRISP mk II - no robot detected
« Reply #1 on: May 14, 2014, 07:32:29 AM »
What color lights on the programmer?

There should be a couple fields on the tool bar - one says what kind of chip you are using, and the other says what kind of programmer. If it says "no tool", click on it, pull down the programmer you are using, and click on the save file icon. You have to save it to get it to work at all. Also check the ISP clock speed and make sure that it is less than 1/4 your CPU speed.
I get paid to play with robots - can't beat that with a stick.

http://www.ltu.edu/engineering/mechanical/bachelor-science-robotics-engineering.asp

Offline StKildaTopic starter

  • Beginner
  • *
  • Posts: 6
  • Helpful? 0
Re: AVRISP mk II - no robot detected
« Reply #2 on: May 14, 2014, 10:37:43 AM »
Thanks.  I had a multitude of problems that i have resolved (a 64 bit pc, not understanding that i didn't need ponyprog, and a misplaced wire on the pcb.

Successfully loaded the photovore file a few moments ago.

One other thing - i see that the servo mod instructions suggest a hex file - but this i assume only for the mega8 chip.  Will i have to manually align the servo motor as I am using the 328P chip?

Another thought is I do have a RC TX / RX in the loft - the hex file must centre the servo?  Soi could i find "centre" by rigging this up instead?

Just got to learn a bit of c now  ....


 


Get Your Ad Here

data_list