go_away

Author Topic: RTX Robot Arm Help  (Read 151 times)

0 Members and 1 Guest are viewing this topic.

Offline RTX_MachineTopic starter

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
RTX Robot Arm Help
« on: June 02, 2014, 10:14:38 AM »
Hi - not sure if anyone can help on here! My son and I have acquired a RTX robot arm (http://www.fcet.staffs.ac.uk/sow1/robot_hardware_resources.htm about half way down the page)  and have spent a couple of weeks working on it, we are now stumped at a particular stage and would really appreciate it if anyone would be able to point us in the right direction. We acquired the RTX from a lady who's father (now deceased) apparently had a hand in designing it and we would love for her to see it working!

The robot was stored in a loft for around 20 years and as such the onboard battery on IP1 board is long dead, it also had a shorted capacitor on the IP0 board which we have replaced. We have bridged out the emergency stop and using Putty on windows XP we can successfully communicate with the ROM through the serial port - on power up the RTX sends:

MSP System Boot
MSP System ROM
Copyright UMI Ltd 1987
Version 01.00
Date 17 June 87

Hi


It then responds to any binary input with "OK". Responses to non binary inputs are "TO ERROR 1", TO ERROR 2" etc. There is no movement of the motors whatsoever. With the motors powered up there is a slight buzzing from the wrist area.

The Interact program on the above site immediately displays READY when the Initialize Robot button is pressed but nothing else. From what we've read the robot should go through a series of movements at that point.

We are assuming that the memory on the boards has been lost and it should be a case of flashing the memory with the RTX original floppy code (and eventually replacing the on board battery). However, we cannot get the START.com or INIT.com programs to work. START returns "RTX not ready", but then says the library has been installed permanently(?). INIT returns "RTX Cannot be initialized" with an error code of $11 (COMMS_NOT_READY) but we did see $20 (NO_RESPONSE) at one point. We have tried running the programs under Win XP command window, and also from a DOS boot disk with the same result.

Many thanks for any help. We would really appreciate any pointers to what we need to do.

 


Get Your Ad Here

data_list