go_away

Author Topic: Axon 1 Programming - Did not receive CONTINUE?  (Read 1398 times)

0 Members and 1 Guest are viewing this topic.

Offline RyltarTopic starter

  • Full Member
  • ***
  • Posts: 74
  • Helpful? 1
Axon 1 Programming - Did not receive CONTINUE?
« on: January 07, 2015, 09:56:22 AM »
Good day,

After long duty as the brains of a demonstration hexapod, my Axon is being repurposed. Over the past couple days, I've programmed it many times using the bootloader with no (well minimal) issues. Sadly, I don't have access my old XP machine anymore otherwise I'd just use that.

Today, I'm getting an error, "Did not receive CONTINUE despite more data to write." I'm assuming it is because the code has grown beyond a certain point, but I'm unable to shrink it down really and according to the make output (webbot lib generated), it is just under 20% of the max file size. Any ideas?

Full Disc, I am using a Mac (hence the minimal issues). I managed to build and compile a bootloader (https://github.com/manisandro/Axon/tree/master/bootloader). This bootloader worked several times before now. I guess I could switch to an ISP programmer or to the Arduino Mega if nothing else works...


Bootloader output below.
Code: [Select]
$ ./bootloader -p AxonSensorSlave.hex -d /dev/tty.SLAB_USBtoUART -b 115200

=================================================
|             BOOTLOADER, Target: V2.1          |
=================================================
COM dev  : /dev/tty.SLAB_USBtoUART
Baudrate : 115200
Program  : AxonSensorSlave.hex
-------------------------------------------------
Waiting for device... Press CTRL+C to exit. |
...Connected!
Bootloader    : V2.1
File "devices.txt" not found!
Target        : 1E9608 (?)
Buffer        :   7168 Bytes
Size available:  64512 Bytes

CRC enabled and OK.
Reading AxonSensorSlave.hex... File read.
Highest address in hex file: 0x03989 (14729 Bytes)
Writing program memory...
Programming "AxonSensorSlave.hex": 00000 - 01C00 failed. Did not receive CONTINUE despite more data to write. Got 0x00FF (255)

Offline RyltarTopic starter

  • Full Member
  • ***
  • Posts: 74
  • Helpful? 1
Re: Axon 1 Programming - Did not receive CONTINUE?
« Reply #1 on: January 08, 2015, 02:19:09 PM »
Might be I somehow kill my Axon, I cannot even get the AVR IPS MK2 (borrowed from campus) to program it. Mismatched device signatures and bad connection status on Mac and a luckily found XP machine.

Offline mklrobo

  • Supreme Robot
  • *****
  • Posts: 516
  • Helpful? 14
  • From Dream to Design at the speed of Imagination!
Re: Axon 1 Programming - Did not receive CONTINUE?
« Reply #2 on: January 25, 2015, 05:55:06 PM »
 :) Hello!
I have not bought one of the Axon at this time. I am learning about it first, buying books,
etc, to collecting info. I expect I will buy one in the near future; but would like to have
chat support form people like you. Keep me posted on your progress....   ;)

 


Get Your Ad Here

data_list