go_away

Author Topic: WebbotLib Studio: UART isRxBufferEmpty function?  (Read 1205 times)

0 Members and 1 Guest are viewing this topic.

Offline GertlexTopic starter

  • Supreme Robot
  • *****
  • Posts: 763
  • Helpful? 24
  • Nuclear Engineer · Roboticist
WebbotLib Studio: UART isRxBufferEmpty function?
« on: July 29, 2015, 09:21:29 AM »
In the past, WebbotLib had a .isRxBufferEmpty() function for UARTs.

Is this no longer the case for the newer versions of the libraries in WebbotLib Studio? E.g. referencing the docs, no such method is listed at: %HOMEPATH%/Documents/webbotstudio/webbot/docs/AVR8/html/classwebbotlib_1_1_uart.html

It would be nice to not have to completely redo code that I've used for years so that it instead uses the .attach() method...
I

Offline mklrobo

  • Supreme Robot
  • *****
  • Posts: 516
  • Helpful? 14
  • From Dream to Design at the speed of Imagination!
Re: WebbotLib Studio: UART isRxBufferEmpty function?
« Reply #1 on: July 30, 2015, 07:08:17 AM »
 ;D  Hello!
I would love to be able to help you, but I have just learned to program the Axon II, and now
am beginning to learn the command structure. I have found, that recently, most people in the
forum somewhere in the same spot I am in. If you have a simple program to turn pins on and off,
that would be a great help!  ;D
I have, however, looked through the docs that I have, and could not find the info you are looking for.  :(

Offline GertlexTopic starter

  • Supreme Robot
  • *****
  • Posts: 763
  • Helpful? 24
  • Nuclear Engineer · Roboticist
Re: WebbotLib Studio: UART isRxBufferEmpty function?
« Reply #2 on: August 09, 2015, 02:56:23 PM »
I stuck with using Webbotlib 2.11 and Project Designer.
I

 


Get Your Ad Here