Author Topic: Yay! The forum is back online again!  (Read 10410 times)

0 Members and 1 Guest are viewing this topic.

Offline Fredrik AnderssonTopic starter

  • Robot Overlord
  • ****
  • Posts: 216
  • Helpful? 0
Yay! The forum is back online again!
« on: December 28, 2007, 01:49:46 AM »
I need to thank you Admin for putting so much effort into this site, even on your vacation! You are definitely the best admin I've ever been in contact with, the one burning most for his community.

Also, didn't get a chance before, so Happy Holidays everyone! :D
Current project: Pirrh - Portable Intelligent Round Rolling Hexapod

Offline SomeSaba

  • Full Member
  • ***
  • Posts: 75
  • Helpful? 0
Re: Yay! The forum is back online again!
« Reply #1 on: December 28, 2007, 01:53:05 AM »
Thank you admin! <3

Offline Mega

  • Full Member
  • ***
  • Posts: 88
  • Helpful? 0
Re: Yay! The forum is back online again!
« Reply #2 on: December 28, 2007, 02:02:36 AM »
Thumbs up for Admin!
Visit my robotics blog at http://megabotblog.blogspot.com/

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #3 on: December 28, 2007, 07:52:17 AM »
 :D

once I know for sure that everything is working, I'll make a system wide announcement to get everyone back

let me know if you guys have any problems or see anything not working

(oh and the youtube button doesn't work yet, having trouble with that still)

Offline Mega

  • Full Member
  • ***
  • Posts: 88
  • Helpful? 0
Re: Yay! The forum is back online again!
« Reply #4 on: December 28, 2007, 08:18:58 AM »
The only things I noticed so far are the youtube button and the avator image had disappeared (I had to re-add this).
Visit my robotics blog at http://megabotblog.blogspot.com/

Offline david_or_johnny

  • Jr. Member
  • **
  • Posts: 25
  • Helpful? 0
Re: Yay! The forum is back online again!
« Reply #5 on: December 28, 2007, 10:06:32 AM »
Got a new server?

Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: Yay! The forum is back online again!
« Reply #6 on: December 28, 2007, 10:08:58 AM »
three cheers for admin :)
United States Marine Corps
Infantry
Returns to society: 2014JAN11

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #7 on: December 28, 2007, 10:47:57 AM »
hmmmm the forum isn't sending out reply emails to me . . . anyone getting them?

Offline ed1380

  • Supreme Robot
  • *****
  • Posts: 1,478
  • Helpful? 3
Re: Yay! The forum is back online again!
« Reply #8 on: December 28, 2007, 11:17:41 AM »
WOOT go admin

you da man  8)
Problems making the $50 robot circuit board?
click here. http://www.societyofrobots.com/robotforum/index.php?topic=3292.msg25198#msg25198

Offline Mega

  • Full Member
  • ***
  • Posts: 88
  • Helpful? 0
Re: Yay! The forum is back online again!
« Reply #9 on: December 28, 2007, 11:36:22 AM »
Quote
hmmmm the forum isn't sending out reply emails to me . . . anyone getting them?
I just got the first one, 15 minutes ago.
Visit my robotics blog at http://megabotblog.blogspot.com/

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #10 on: December 28, 2007, 11:47:11 AM »
Im confused now . . . I just got one from the forum . . . but didn't get any others including from this topic . . . I can't seem to send myself an email to my robots@[sor].com address . . . yet I got one from someone else . . . Let me know if anyone else notices this, so I can narrow down the cause(s) . . .

I guess I got a lot of work ahead of me . . .

Offline Trumpkin

  • Supreme Robot
  • *****
  • Posts: 1,177
  • Helpful? 5
Re: Yay! The forum is back online again!
« Reply #11 on: December 28, 2007, 05:53:56 PM »
I'm sooo happy!  ;D
Robots are awesome!

Offline Rebelgium

  • Supreme Robot
  • *****
  • Posts: 638
  • Helpful? 0
  • It's called the future ... We like it here
Re: Yay! The forum is back online again!
« Reply #12 on: December 28, 2007, 06:40:42 PM »
Aah feels good to be able to post in the forum again  :D
The downtime gave me more time to study for my exams though... :P

I completely understand the crappyness of the situation admin (atleast i think so) , My brother has had the same thing several times >:(. (not this host though)
Damn hosts that delete your site, without even taking a frigging backup, and without even a notice !! Because the site uses too much bandwith...
To relax after some hard work on robotics: A very fun free online text based MMORPG
orgcrime.net

Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: Yay! The forum is back online again!
« Reply #13 on: December 28, 2007, 11:13:15 PM »
I couldnt send you an email to the robots@[sor].com address either admin, while the forums were down. I havnt tried since theyve been back up... should I?
United States Marine Corps
Infantry
Returns to society: 2014JAN11

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #14 on: December 29, 2007, 12:49:47 AM »
Quote
I couldnt send you an email to the robots@[sor].com address either admin, while the forums were down. I havnt tried since theyve been back up... should I?

yes please! I had to re-enable the email forwarding after the site move, so you probably emailed me before then.

I'm having serious issues getting the youtube button back . . . it keeps giving me the 'Some of the files the package manager needs to modify are not writable' warning but not telling me which files to chmod/create . . .
If anyone wants to help and knows a little xml, have a look here and tell me what files need changing:
http://www.simplemachines.org/community/index.php?topic=197280.0

When I made the port over, file locations got all mixed up, but not sure which ones . . . and not all my files were backed up to the most recent versions :-\

Im also still working on getting Members Tutorials working . . . I reinstalled all the software, but haven't uploaded the database yet . . .

bunch of little things fixed too . . .

hmmm its 2am . . . I need to sleep now . . .

Offline Asellith

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 648
  • Helpful? 9
  • "I'm a leaf on the wind. Watch how I soar"
Re: Yay! The forum is back online again!
« Reply #15 on: December 29, 2007, 11:54:31 PM »
Alright I can get my forum fix again. How I have missed the forum! Thanks Admin! now where did I put that post about wifi positions I have needed to review for the last few days :)

Johnny B
Jonathan Bowen
CorSec Engineering
www.corseceng.com

Offline creedcradle

  • Full Member
  • ***
  • Posts: 92
  • Helpful? 0
  • Physics Robotics
Re: Yay! The forum is back online again!
« Reply #16 on: December 30, 2007, 12:48:14 AM »
SOR is back and the Robot Power is Back....

but Admin youtube clips are missing... ???
LEARN TO SHARE and SHARE TO LEARN!

Offline Rebelgium

  • Supreme Robot
  • *****
  • Posts: 638
  • Helpful? 0
  • It's called the future ... We like it here
Re: Yay! The forum is back online again!
« Reply #17 on: December 30, 2007, 09:25:26 AM »

but Admin youtube clips are missing... ???

Yes, we know. Admin is working on it. :)
To relax after some hard work on robotics: A very fun free online text based MMORPG
orgcrime.net

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #18 on: December 30, 2007, 02:09:56 PM »
After spending like 7 hours on the problem, I ended up just learning how to do xml and php to reverse engineer the code and manually reprogram all the files needed to get youtube vids working again.

In short, youtube vids now work.

Only like a million more things left to solve . . .  :'(

Also, I never got a recent backup of the attachments folder. Meaning, that if you attached a file to the forum in the last 2 months, it was lost. If you made a post with an attachment, could you reupload it to your posts?

Thanks everyone for bearing with me!!!

Offline Steve Joblin

  • Supreme Robot
  • *****
  • Posts: 405
  • Helpful? 2
Re: Yay! The forum is back online again!
« Reply #19 on: December 30, 2007, 02:13:32 PM »
is it me or does the forum have a totally new look and feel suddenly?

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #20 on: December 30, 2007, 04:06:54 PM »
oops sorry about that. It works now right?

I overwrote some files when I added youtube, and apparently I overwrote a 'use custom theme' setting in the process . . .

Let me know if anything else doesn't work or breaks later on . . .

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #21 on: December 30, 2007, 04:10:13 PM »
Oh and for the coders out there that want to browse the web and help me figure out the problems I am having, check here:
http://www.simplemachines.org/community/index.php?topic=213862.msg1362706#msg1362706

Offline Steve Joblin

  • Supreme Robot
  • *****
  • Posts: 405
  • Helpful? 2
Re: Yay! The forum is back online again!
« Reply #22 on: December 30, 2007, 04:17:58 PM »
Thanks Admin... looking good now... thought I was going crazy there for a second!

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #23 on: December 30, 2007, 08:20:07 PM »
Quote
Thanks Admin... looking good now... thought I was going crazy there for a second!

yea i didn't catch it because for some reason the admin account can see a different theme, and for some reason my theme wasn't changed . . .


Ok so I got some good news and some bad news about the Members Tutorials. The good news is that I got it back up and running with zero data lost (hurray!). Bad news is that I hadn't backed up the uploaded files (pics and source code) in a long time, so many of those got lost.

If you wrote a tutorial, can you please please please check it to make sure all files are there! (and of course make any fixes). Also, let me know if anything odd happens or doesn't work because I might not have got all the files set properly . . .

I also figured out why I wasn't getting emails. It was a combination of not setting up the return address correctly, and the strange unchecking of the 'Notify me of replies' box when I ported the forum . . .

Lastly, I've learned a lesson from this. Don't trust my host is one of them. The other is that weekly backups isn't often enough, and its annoying to do. Anyone know a program that can be scheduled to back up my entire site onto my laptop automatically? This includes MySQL exports . . .

Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: Yay! The forum is back online again!
« Reply #24 on: December 30, 2007, 08:56:08 PM »
You could write a simple batch file that copies entire folders to a pre-determined destination and just have your computer run that batch file every 12 or 24 hours... or even every 6 hours O_O lol
United States Marine Corps
Infantry
Returns to society: 2014JAN11

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #25 on: December 30, 2007, 09:09:44 PM »
Quote
You could write a simple batch file that copies entire folders to a pre-determined destination
You confuse me for a skilled programmer :P

I haven't a clue on how to get a batch file to ftp files and export MySQL databases . . . was hoping there is a program to just do it all for me . . . know a good tutorial to read up on?

(yea I know, I do lots of web and embedded programming, but it takes me 10x longer than the average person to figure it all out ;D)

Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: Yay! The forum is back online again!
« Reply #26 on: December 30, 2007, 10:46:42 PM »
well a batch file is a simple file that executes commands into the DOS prompt. You would have to tell it to copy each individual file or folder to whatever destination you want. But thats assuming youve got a direct network connection to the drive that the files are on :-\
United States Marine Corps
Infantry
Returns to society: 2014JAN11

Offline paulstreats

  • Supreme Robot
  • *****
  • Posts: 1,381
  • Helpful? 21
Re: Yay! The forum is back online again!
« Reply #27 on: December 31, 2007, 08:24:37 AM »
a little difference ive noticed that is probably at the very bottom of the list is that pictures and links dont open in a new window like they used to

EDIT

Sorry, links do open in a new window, but the links to pictures dont (did they ever?)
« Last Edit: December 31, 2007, 08:26:20 AM by paulstreats »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Yay! The forum is back online again!
« Reply #28 on: December 31, 2007, 08:29:14 AM »
Quote
Sorry, links do open in a new window, but the links to pictures dont (did they ever?)
are you referring to image attachments?

or just external links?

Offline paulstreats

  • Supreme Robot
  • *****
  • Posts: 1,381
  • Helpful? 21
Re: Yay! The forum is back online again!
« Reply #29 on: December 31, 2007, 08:46:17 AM »
the image attatchments below the images.

Ive just realised why too, its because it downloads the image and my browser opens it from this computer but it reuses the browser window.

Sorry

 


Get Your Ad Here