Author Topic: 7805 Regulator Voltage out Dropping  (Read 1350 times)

0 Members and 1 Guest are viewing this topic.

Offline hazzer123Topic starter

  • Supreme Robot
  • *****
  • Posts: 460
  • Helpful? 3
7805 Regulator Voltage out Dropping
« on: January 30, 2008, 03:29:19 PM »
I have a KA7805A voltage regulator and i am placing 12V of p.d. across the Vin and GND pins. This is well below the max input voltage of 40V.
The Vout pin gives a nice steady roughly 5.05V when connected to my motor driver board. All the electronics work fine.

When i attach the Vout and GND to both my motor driver board and my main MCU board, which i send the power to down the 4Wire ICD cable (+5v,GND,SCL,SDA), the Vout pin becomes 2.6V.

The is hardly any current through the voltage regulator ( it is rated at 1Amp max). All it is powering is 2 PICs, a couple of LEDs and a Sharp IR. The voltage regulator doesn't noticably heat up.

Any ideas on what could be happening and how to fix it?

Thanks
Imperial College Robotics Society
www.icrobotics.co.uk

Offline hazzer123Topic starter

  • Supreme Robot
  • *****
  • Posts: 460
  • Helpful? 3
Re: 7805 Regulator Voltage out Dropping
« Reply #1 on: February 01, 2008, 11:40:26 AM »
Got another voltage regulator today, replaced the old one, and it works.

Just to let you know.
Imperial College Robotics Society
www.icrobotics.co.uk

Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: 7805 Regulator Voltage out Dropping
« Reply #2 on: February 01, 2008, 11:57:30 AM »
Try making another proto circuit using just like 4 or 5 LEDs and have the supposed broken VReg to power the 5 LEDs in parallel. See if perhaps that vreg is still usable for things.
United States Marine Corps
Infantry
Returns to society: 2014JAN11

 


Get Your Ad Here