2

Author Topic: $50 robot programming problem  (Read 1982 times)

0 Members and 1 Guest are viewing this topic.

Offline goatfishTopic starter

  • Full Member
  • ***
  • Posts: 117
  • Helpful? 1
$50 robot programming problem
« on: March 29, 2008, 11:51:30 PM »
i just downloaded AVR studio to make the code for the robot,i followed all instructions and went rebuild all and it has come up with this




Build started 30.3.2008 at 16:47:52
avr-gcc.exe  -mmcu=atmega128 -Wall -gdwarf-2 -O0 -MD -MP -MT Photovore_v1.o -MF dep/Photovore_v1.o.d  -c  ../../Photovore_v1.c
avr-gcc.exe -mmcu=atmega128  Photovore_v1.o     -o photovore_v1.elf
Photovore_v1.o: In function `main':
C:\my robots\photovore_v1\default/../../Photovore_v1.c:41: undefined reference to `a2dInit'
C:\my robots\photovore_v1\default/../../Photovore_v1.c:42: undefined reference to `a2dSetPrescaler'
C:\my robots\photovore_v1\default/../../Photovore_v1.c:43: undefined reference to `a2dSetReference'
C:\my robots\photovore_v1\default/../../Photovore_v1.c:56: undefined reference to `a2dConvert8bit'
C:\my robots\photovore_v1\default/../../Photovore_v1.c:57: undefined reference to `a2dConvert8bit'
make: *** [photovore_v1.elf] Error 1
Build failed with 5 errors and 0 warnings...





   what do i need to do



*i just opened it again and went rebuild all and it has siad it has no errors,what the hell is going on  :P :-[ :-\ :'( :(*



*it appera that all those errors were because i was opening a file i had made,wheni open the SoR photvre_v1 file it has no errors when i rebuild*
« Last Edit: March 29, 2008, 11:56:49 PM by goatfish »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: $50 robot programming problem
« Reply #1 on: March 30, 2008, 01:23:49 PM »
This question has been posted several times already. Each time, it was resolved when the person went back and carefully read all the instructions.

You missed a step ;)

Offline goatfishTopic starter

  • Full Member
  • ***
  • Posts: 117
  • Helpful? 1
Re: $50 robot programming problem
« Reply #2 on: March 30, 2008, 06:31:46 PM »
yes i forgot that configuartion options,duh,man im dumb lol :P :o

 


Get Your Ad Here

data_list