Author Topic: $50 Robot questions - final stages/newb questions  (Read 2717 times)

0 Members and 1 Guest are viewing this topic.

Offline jonnylocksTopic starter

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
$50 Robot questions - final stages/newb questions
« on: May 08, 2008, 03:18:20 AM »
First off I am an absolute newb to robotics, electronics, and programming. That said, the tutorial is very helpful and I have spent hours on these forums reading valuable information. Thanks.

With alot of difficulty, I have soldered the circuitboard together and plugged in the 6 pin, more expensive cord. After fooling around with the ISP frequency in AVR studi, the photovore program and the servo program writes, reads and verifies successfully (sometimes, randomly, it does not). Each time I erase then upload the program, one of the two servos just slightly moves (not even 90 degrees) then stops. Thats it. Sometimes it doesnt even do that. I thought this was 'centering', but it happens whether it is the photovore program or the servo program. 

I have not used a multimeter yet (I will do this today), I do not have the photosensors plugged in and I have not modded the servo yet (how could I if the program won't work?).

Some questions are substantive.. some are just for my understanding:

1 - If AVR Studio successfully writes, reads and verifies the program.. doesn't this mean that the circuitry connected to the 9V is correct and I don't have to even check that side w/ the multimeter?

2 - If the Servo moves slightly, what does this mean about the circuitry?

3 - Do I need the photosensors plugged in to run 'photovore' and have it move the servos continously? If it is unmodded, how are the servos supposed to react?

4 - My LED doesn't light up.. what gives? I checked that the positive and negative are in the right place.

5 - My ISP frequency in AVR Studio is at 200khz.. I understand 1/4 should be 2mhz.. I read the post on this but it is still not clear. Is 200khz sufficient since it is writing OK (most of the time)? Might this have something to do with the fact that it only writes, reads and verifies SOME of the time. 

Sorry for the dumb questions but like I said this is all absolutely new to me. Again, nice helpful forums here! Thanks!

 

Offline pomprocker

  • Supreme Robot
  • *****
  • Posts: 1,430
  • Helpful? 16
  • Sorry miss, I was giving myself an oil-job.
Re: $50 Robot questions - final stages/newb questions
« Reply #1 on: May 08, 2008, 10:22:12 AM »
1. If you can successfully program the atmega8, that means the chip has enough voltage to operate and that your 6 pin header is properly connected to the chip. that doesnt say anything about how the rest of your circuit is connectivity wise.

2. the servo is not the proper tool for making any assumptions about your circuit. please use a multimeter.

3. In all reality, you need to build the circuit first before modifying your servos. that way you can upload the hold servo hex and have it hold the servos centered while you modify them. although before even doing this you need to make sure that there is a common ground throughout the entire circuit. and that there is connectivity between the atmega8 and the inner i/o headers that you soldered on. (remember the outer one is ground, the middle one is power, and the inner one is the i/o) then make sure your power is 5v for the regulated side, and approx 5 volts for the unregulated side.

4. mine doesnt light up either. they seem to go bad really easy. make sure that since the led is wired to i/o pins 4 on that side that you are getting power to it. also a good way to test leds before soldering them is to pinch a watch battery between the anode and cathode of the led. (by the way, admin can't get his working either)

5. not sure on this one. (read the manual)


Offline edwardcphipps

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
Re: $50 Robot questions - final stages/newb questions
« Reply #2 on: May 11, 2008, 11:40:15 PM »
hi there edward here from new zealand . Can you give me the parts list for the augmented micro controller ? thanks i went into the local shops but i need the actual parts list like what kind of capacitors etc Thanks

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: $50 Robot questions - final stages/newb questions
« Reply #3 on: May 17, 2008, 06:28:34 PM »
edwardcphipps, he is using this tutorial:
http://www.societyofrobots.com/step_by_step_robot.shtml

 


Get Your Ad Here