General Misc > Misc

some real problems

(1/1)

andreahmed:
im trying to make a line follower robot , the sensors are constructed by compartors with the LDRs,they work well, but the robot moves very fast , it can detect the line , but it cant move at the turns , i attached the pic with the illustrations , also it seems that the sensor affected by ambient light should i cover it right ? , also i've a problem that the two motos arent equal in speed they are used motors so what can i do ?

now im using two Sensors , can just two work well for this purpose ?
truth table
0 0 move forward
1 0 rotate right
0 1 rotate left
1 1 move forward
thanks alot
http://i9.tinypic.com/3ynia77.jpg

Hal9000:
If something is affected by ambient light, I think covering is a good idea, although facing sensors directly toward the ground is also a very good idea for reducing this. What you could also do is paint parts of the sensor (e.g the sides of a photoresistor) to give it 'direction'.

I had a problem with my motors too. I guess there are 4 things you could try. The 3rd is obviously the most feasible / non stupid lol.

1) Put a brake of some sort on the faster wheel - bad idea
2) Reduce the power going to the faster wheel - could be done I suppose, but very fiddly!
3) Produce a control algorithm to detect how far the robot has gone on one side compared with the other. You could use shaft encoders or something like that. I would imagine with line following, great accuracy for motors is not needed unless you are going very fast.
4) Make one wheel bigger than the other - bad idea

I hope I have helped. These ideas are pretty lame, however.

Navigation

[0] Message Index

Go to full version