Author Topic: Servos run slow  (Read 1831 times)

0 Members and 1 Guest are viewing this topic.

Offline koolboarder007Topic starter

  • Jr. Member
  • **
  • Posts: 9
  • Helpful? 0
Servos run slow
« on: September 18, 2008, 05:08:47 PM »
My $50 robot is complete, but I noticed my servos tend to rotate slower than some of the videos I've seen on line. I'm wondering if they used a different servo or if maybe I modified the servo incorrectly and it now runs much slower. Has anyone else experienced this problem? How can I make my servos run faster? Here is a youtube video of my robot in actions. You will see that it functions correctly, jitters a little bit in correction, but moves really slow.

[youtube]http://www.youtube.com/watch?v=cDkXXpCU7AI[/youtube]

If anyone can give me some pointers it would be greatly appreciated. Thanks!

Regards,

Will

Offline pomprocker

  • Supreme Robot
  • *****
  • Posts: 1,430
  • Helpful? 16
  • Sorry miss, I was giving myself an oil-job.
Re: Servos run slow
« Reply #1 on: September 18, 2008, 05:36:00 PM »
bigger wheels

or

change the servo speed in the robot_go_straight function.


23/.992*(milliseconds) = delay cycles

for a servo 1.5 milliseconds is centered (or stand still on a modified servo). 2.0 is max, 1.0 is min. so since your servos are mounted and one is flipped you have to put one at full max and one at full min.

I believe the numbers right now are 25 and 44.

you can make your robot go a little faster by changing them to the max and min

23/.992*(2.0) = 46
23/.992*(1.0) = 24

so change 25 to 24 and 44 to 46

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Servos run slow
« Reply #2 on: September 18, 2008, 05:45:27 PM »
your robot also looks pretty heavy

 but if you do what pomprocker  says you can compensate for that

BTW  nice robot!
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline koolboarder007Topic starter

  • Jr. Member
  • **
  • Posts: 9
  • Helpful? 0
Re: Servos run slow
« Reply #3 on: September 18, 2008, 11:09:58 PM »
Thank you for the suggestions. I will definitely give this a try and see if it makes a difference. I actually found one of those erector sets from target on sale for cheap so i built my structure from that kit. Anyway, i'll modify it a bit and see if that makes a difference. Thank you!

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Servos run slow
« Reply #4 on: September 21, 2008, 06:40:33 PM »
Increase wheel diameter to increase speed, the servos have enough torque for it.

 


Get Your Ad Here