go_away

Author Topic: Help with broken Axon USB connector  (Read 2051 times)

0 Members and 1 Guest are viewing this topic.

Offline mbatemanTopic starter

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Help with broken Axon USB connector
« on: October 17, 2008, 08:00:50 AM »
OK, I messed up. I forgot to unplug the USB cable before walking off with the robot. It pulled the USB connector's case away from the Axon circuit board. The pins are all still connected as are the two metal tabs on one side. The tabs on the other side pulled loose. If I press down on the metal connector case, it works, but if I just leave those two tabs floating, it does not. I cannot tell if there is circuitry that they connect to, but I assume there must be since I have to press down to make it work. I tried clamping it down gently and heating up the solder in the hopes that it would reconnect to whatever is underneath, but that did not work. I thought about superglueing it down, but was afraid the glue might cover whatever contact might be under there. I have photos posted at http://picasaweb.google.com/mdbateman/BrokenAxonUSB. Any help would be greatly appreciated.

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: Help with broken Axon USB connector
« Reply #1 on: October 19, 2008, 04:26:54 AM »
lol first Axon casualty!

Don't worry this is an easy fix. The tabs don't actually do anything other than simply hold the USB connector on. Just solder them back on, and use extra solder just in case it happens again :P

What appears to be happening is that one or more pins has an intermittent connection, meaning that it only has good contact when you push down.

Get out your soldering iron and add a little more solder to each of the 5 pins. Be careful to not short the pins with solder, as its really hard to unshort them unless you have solderwick.

Let me know how it goes!

Offline mbatemanTopic starter

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Re: Help with broken Axon USB connector
« Reply #2 on: October 19, 2008, 09:26:26 AM »
I tried soldering the tabs back down, but there does not appear to be anything to solder them to. The pads that they are soldered to pulled out of the circuit board. Can I just superglue the tabs back into place?

Offline Trumpkin

  • Supreme Robot
  • *****
  • Posts: 1,177
  • Helpful? 5
Re: Help with broken Axon USB connector
« Reply #3 on: October 19, 2008, 02:48:32 PM »
Try hot glue to hold them down.
Robots are awesome!

Offline mbatemanTopic starter

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Re: Help with broken Axon USB connector
« Reply #4 on: October 20, 2008, 08:14:25 AM »
I took a close look and see that Admin is correct. The actual signal pins broke their solder connection. I will try to solder them back down, but they are really tiny and close together. I hope I done mess it up.

Offline mbatemanTopic starter

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Re: Help with broken Axon USB connector
« Reply #5 on: October 20, 2008, 11:34:13 AM »
Woot! It's alive! I was able to solder the pins back down, and a little superglue will hold the case in place. Thanks!

 


Get Your Ad Here