Author Topic: Serial port  (Read 1637 times)

0 Members and 1 Guest are viewing this topic.

Offline vishalsaxenaTopic starter

  • Jr. Member
  • **
  • Posts: 23
  • Helpful? 0
Serial port
« on: October 31, 2008, 10:06:50 PM »
Hey people I have assembled almost everything in my $50 robot nd learnt alot.....
thnx to Admin......  :D :D
But I think my Serial port is not working properly >:( >:(........ I shorted 2&3 pin of my
serial port and ran Hyper Terminal program and did what is needed but this test failed
so does it mean that my serial port is not working or somehow its deactivated???
Please help!! ??? ???

Thank You
Vishal Saxena

Offline BuddingContraptionist

  • Jr. Member
  • **
  • Posts: 44
  • Helpful? 0
Re: Serial port
« Reply #1 on: November 01, 2008, 08:38:37 AM »
did you set flow control to none?

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,632
  • Helpful? 169
    • Society of Robots
Re: Serial port
« Reply #2 on: November 04, 2008, 12:13:06 AM »
Check over everything with a voltage meter to find anything unusual. You probably just made a soldering mistake.

Are you using a serial to USB adapter?

Offline Half Shell

  • Robot Overlord
  • ****
  • Posts: 225
  • Helpful? 0
Re: Serial port
« Reply #3 on: November 04, 2008, 08:26:39 AM »
Also, hyperterminal can be a bit.... touchy at times.

I highly recommend for you to use Putty! It can do serial communication as well as telnet and SSH.

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

It's also free and can run in RAM if you really want.

 


Get Your Ad Here