go_away

Author Topic: Bootloader Slowdown  (Read 8945 times)

0 Members and 1 Guest are viewing this topic.

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Bootloader Slowdown
« on: November 23, 2008, 11:30:31 AM »
My bootloader is really slow now it takes a minute to program the Axon when it used to take like 3 seconds.

Heres what I did : Changed COM setting to COM5 from COM3 for some stupid reason. Then realized COM3 was actually better to use than COM5 so then I switched back to COM3. I made sure command line is correct. Any idea why its so slow now? I mean it programs correctly after a minute but its still sooo slow.
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline mbateman

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Re: Bootloader Slowdown
« Reply #1 on: November 23, 2008, 05:51:01 PM »
I'm running at 15200, and mine has always taken a minute or so to program. I would love to know what you change if you do get it back to a few seconds.

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #2 on: November 23, 2008, 05:57:36 PM »
I'm running at 15200, and mine has always taken a minute or so to program. I would love to know what you change if you do get it back to a few seconds.
Oh really?

It took literally less than 5 seconds before. And this was for the past month or more . It was never this slow. I'm gonna try burning the bootloader once more.
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #3 on: November 23, 2008, 08:50:28 PM »
hmmmmm seems really odd . . . I've never seen this before!

Can you guys explain your hardware? Is it just a USB2 connection straight from your PC directly to the Axon, no adapters? WinXP?

airman00, try reinstalling the USB drivers too. I'm guessing you tried the basics like restarting your computer? Why is COM3 better than COM5? Does this only happen on COM3 or all the ports now? Let me know how reinstalling the bootloader goes.

Quote
I'm running at 15200
You guys mean 115200? Try other baud rates and see how it goes.

Offline mbateman

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Re: Bootloader Slowdown
« Reply #4 on: November 23, 2008, 11:55:12 PM »
Yes, 115200, 8 bits, no parity, 1 stop bit, no flow control. Win XP Pro SP3. Silicon Labs CP210x USB to UART Bridge (COM4) v5.3.0.0. Direct USB cable from PC to Axon.

FBOOT17.EXE -b115200 -c4 -paxon.hex -vaxon.hex

It takes about 25 seconds for each phase (load and verify).

I did notice that I had a typo in my FBOOT17.EXE command at first. I originally had -b15200 instead of -b115200. But changing that made no difference.

I then "updated" the USB driver, and it actually seems to have downgraded it to 4.80.1.0. After the update, it thought COM4 was in use, so it used COM5, but the FBOOT17.EXE command does not like -c5. It seems to interpret that as COM1 for some reason. So I reattached the driver to COM2 and used -c2. That works, but made no difference in the speed.

My hex code size is 0x7CB5. When it is smaller, it does load faster, but it does not seem like it should take so long at 115200.

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #5 on: November 24, 2008, 11:04:52 PM »
I get the same thing when using COM5 or higher - shows up in cmd prompt as COM1 and doesnt work
I haven't had a chance to play with it yet, maybe later this week.
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #6 on: November 24, 2008, 11:38:03 PM »
Well . . . the fact it happened to two people narrows it down a bit . . . I've never had the problem, so can't really debug it :P

airman00, you have two Axons no? does it only happen to one, or both? If it only happened to one, that means it could be an Axon hardware issue. Just let me know your results after playing around with it for a bit.

Before shipping I test every single Axon, including the bootloader. Every single one loaded super fast without problems . . . mbateman, was it always like this since day one?

mbateman, try different baud rates such as 57600, and let me know if it speeds up at all.

Offline mbateman

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Re: Bootloader Slowdown
« Reply #7 on: November 25, 2008, 06:22:10 PM »
Yes, it has been like this since day one, so I did not know it should be faster until airman00 started this post.

I have tried several different rates using the -b command line option. Nothing made much difference until I went all the way down to 1200, then it was really slow, but that would be expected.

BTW, I'm not sure how all the settings play together, but the different -b settings all worked (although slowly) regardless of what the COM port baud rate was set to. I'm not sure if that is the expected behavior or not.

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #8 on: November 25, 2008, 07:38:52 PM »
I reinstalled hte driver and its till very slow . Its upsetting

Attached is a screenshot of the device details
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #9 on: November 25, 2008, 10:51:35 PM »
airman00, please try out the other Axon too. If it just happens to one, that could mean its a hardware issue. ;D

Also, what .hex file sizes are you guys uploading? Does it also happen with the demo .hex files?

I decided to compile and test the latest bootloader today to see if that will fix your problems. Please try it out here and let me know if it fixes anything:
http://www.societyofrobots.com/robotforum/index.php?topic=5932.0

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #10 on: November 26, 2008, 05:59:51 AM »
airman00, please try out the other Axon too. If it just happens to one, that could mean its a hardware issue. ;D

yea i tried it out with the other one also , same slow speed. Its definitely the computer issue
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline mbateman

  • Full Member
  • ***
  • Posts: 82
  • Helpful? 0
Re: Bootloader Slowdown
« Reply #11 on: November 26, 2008, 08:33:49 AM »
I just tried it with axon_tst.hex and had the same results. It was a tiny bit faster, but that is just because it is a smaller hex file. But it still took ~15-20 seconds per phase.

I do not have an external hardware programmer.

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #12 on: November 26, 2008, 08:38:50 AM »
hmm maybe its a driver problem. Because I remember that I switched from COM3 to COM5, set a different device to COM3, and then set the Axon to be connected to COM3.

Is there some easy to use COM port manager that can show what ports are set for what ( besides Device Manager) ?
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #13 on: November 26, 2008, 09:13:47 AM »
airman00 did you ever buy that hardware programmer? It's probably not the bootloader on the Axon however, but it's something to rule out.

I'm starting to suspect FBOOT.EXE is the cause. I'll see if I can fix FBOOT (it's open source). Glancing at the code, it only supports COM1-4. I *think* I can fix that easily. If only 'open source' meant 'has comments to explain code' :P

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #14 on: November 26, 2008, 09:26:36 AM »
airman00 did you ever buy that hardware programmer? It's probably not the bootloader on the Axon however, but it's something to rule out.
Yea i have the hardware programmer , you want me to try regular ISP without the bootloader?

And I'm using COM3 NOT COM5.
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline pomprocker

  • Supreme Robot
  • *****
  • Posts: 1,430
  • Helpful? 16
  • Sorry miss, I was giving myself an oil-job.
Re: Bootloader Slowdown
« Reply #15 on: November 26, 2008, 11:37:26 AM »
i also looked at modifying fboot.exe some time ago, it looks like there is a one line simple fix to adding more com ports, but I could be wrong also :P

airman00 did you ever buy that hardware programmer? It's probably not the bootloader on the Axon however, but it's something to rule out.

I'm starting to suspect FBOOT.EXE is the cause. I'll see if I can fix FBOOT (it's open source). Glancing at the code, it only supports COM1-4. I *think* I can fix that easily. If only 'open source' meant 'has comments to explain code' :P

Offline izua

  • Supreme Robot
  • *****
  • Posts: 682
  • Helpful? 0
Re: Bootloader Slowdown
« Reply #16 on: November 26, 2008, 11:49:50 AM »
remember to add the size of the hex file you're downloading, and if you are doing/not doing verification.
if you download a huge hex file, it's natural to take a long time. which is doubled, when you verify.
Check out my homepage for in depth tutorials on microcontrollers and electronics.

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #17 on: November 28, 2008, 02:36:32 AM »
Quote
Yea i have the hardware programmer , you want me to try regular ISP without the bootloader?

Yea, use the regular ISP method to upload the updated bootloader hex I included earlier in this thread. Then reattempt the regular bootloader method again. Basically its a firmware replacement.

Quote
i also looked at modifying fboot.exe some time ago, it looks like there is a one line simple fix to adding more com ports, but I could be wrong also

pomprocker, according to your posts here it is more difficult than it looks:
http://www.societyofrobots.com/robotforum/index.php?topic=5939.0
 ;D

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #18 on: December 14, 2008, 12:28:29 AM »
I replaced the bootloader on both axons and its still really really slow.
I followed these instructions : http://www.societyofrobots.com/axon/axon_FAQ.shtml#upload_bootloader
Anything else I should try?
« Last Edit: December 14, 2008, 12:30:17 AM by airman00 »
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline pomprocker

  • Supreme Robot
  • *****
  • Posts: 1,430
  • Helpful? 16
  • Sorry miss, I was giving myself an oil-job.
Re: Bootloader Slowdown
« Reply #19 on: December 14, 2008, 03:00:48 AM »
i hate bootloaders...more trouble than theyre worth

I found this table for recommended settings

UART being your FIFO Buffers setting on the windows xp

COM Port    3
Input/Output (Address)  03E8
IRQ  4 or 5
UART 16550
« Last Edit: December 14, 2008, 03:10:18 AM by pomprocker »

Offline Ro-Bot-X

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 1,431
  • Helpful? 25
  • Store: RoBotXDesigns.ca
Re: Bootloader Slowdown
« Reply #20 on: December 14, 2008, 01:20:25 PM »
...
Anything else I should try?

Yes. Use a real serial port instead of USB. It does not make ANY of these problems. I have a bootloader on a mega168 I am using with Bascom from a serial port on my laptop. It loads the code much faster than the USB virtual serial port I use for the Axon. I also have a RS232-TTL dongle that I might be able to plug directly to the UART pins on the Axon, to see if the code loads faster. Too bad this UART is not connected to a 3 pin header...
Check out the uBotino robot controller!

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #21 on: December 27, 2008, 03:35:42 AM »
Quote
I also have a RS232-TTL dongle that I might be able to plug directly to the UART pins on the Axon, to see if the code loads faster. Too bad this UART is not connected to a 3 pin header...
Ok I got the hint ;D . . . I just wrote a bootloader that you can use with UART0. See attached.

(note I haven't tested it myself as I didn't bring an USB adapter with me to Bangkok)

Let me know how it goes. If its fast like its supposed to be, that means the USB itself is slowing down the bootloader.

Offline VOne

  • Jr. Member
  • **
  • Posts: 14
  • Helpful? 0
Re: Bootloader Slowdown
« Reply #22 on: January 12, 2009, 01:22:03 PM »
Has anyone had success with this yet?  I used to get 40 second loads, but I thought it was just my old laptop with the slow usb ... but I now have a brand new laptop, and my load speeds are still around 46 seconds for 19K ...




Offline pomprocker

  • Supreme Robot
  • *****
  • Posts: 1,430
  • Helpful? 16
  • Sorry miss, I was giving myself an oil-job.
Re: Bootloader Slowdown
« Reply #23 on: January 12, 2009, 01:34:01 PM »
it says 115200k, maybe you have some things not configured to match?

Offline adasta

  • Beginner
  • *
  • Posts: 5
  • Helpful? 1
Re: Bootloader Slowdown
« Reply #24 on: February 03, 2009, 01:25:21 PM »
I think I figured out a fix for the slow Bootloader.  Use windows SP2 and not SP3.

When I first started using the axon, I was getting a 6 second boot load.  Then when I reformatted my system and updated to the latest XP release, I was getting the 45 second boot loads.  Now, with SP3 removed, I am back to six second land.

Anyway, to remove sp3, go to start ---> control panel--> add remove applications -> windows XP SP3
and remove it.

-Hope this works for everyone else.

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #25 on: February 03, 2009, 09:19:40 PM »
adasta, that might actually be it!

I am still using SP2 as I heard about all the problems and zero benefits offered by SP3. I still have ~6 second loads.

Can anyone else verify their SP2 and SP3 bootloader speeds?
« Last Edit: February 03, 2009, 09:20:23 PM by Admin »

Offline airman00Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Bootloader Slowdown
« Reply #26 on: February 03, 2009, 09:33:09 PM »
VERIFIED!!!

I'm back to my 5 second bootloader programming speed!

Thanks adasta!!!   ;D
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline pomprocker

  • Supreme Robot
  • *****
  • Posts: 1,430
  • Helpful? 16
  • Sorry miss, I was giving myself an oil-job.
Re: Bootloader Slowdown
« Reply #27 on: February 05, 2009, 01:41:46 AM »
With SP3, You can try deleting your USB controllers in Device Manager and then having them automatically re-detected.

Make sure your USB device shows up under the 'enhanced/usb2 controller'

Offline VOne

  • Jr. Member
  • **
  • Posts: 14
  • Helpful? 0
Re: Bootloader Slowdown
« Reply #28 on: May 13, 2010, 12:34:30 PM »
Hi Guys,

I still have this problem, loading takes a full minute from my XP SP3.  I have tried re-installing my USB ports, but it is still slow - and its kindof getting annoying - especially knowing that it used to be 5 seconds.

I have not had time for robots in a year now, but now I am back - and hoping there is a solution for this - perhaps I should download the new boot loader?

Thanks!
Vone

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,658
  • Helpful? 169
    • Society of Robots
Re: Bootloader Slowdown
« Reply #29 on: May 13, 2010, 08:48:44 PM »
Well, we need a new solution within the next 2 months . . .

Quote
Support for Windows XP with Service Pack 2 (SP2) will end on July 13, 2010.


http://windows.microsoft.com/en-us/windows/help/end-support-windows-xp-sp2-windows-vista-without-service-packs?os=other


The USB chip firmware has had a bunch of bug fixes lately, try this out and see if the problem still exists:
http://www.silabs.com/products/mcu/pages/usbtouartbridgevcpdrivers.aspx

 


Get Your Ad Here