Author Topic: SHARP IR GP2D15 is Not Turning On  (Read 2460 times)

0 Members and 1 Guest are viewing this topic.

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
SHARP IR GP2D15 is Not Turning On
« on: November 26, 2008, 07:33:23 PM »
I have a somewhat big problem.

During the summer, I bought 2 GP2D15 IR sensors (the one with digital output). I've only just tested them a few hours ago.

I didn't get a reading during my initial test (just putting 5V through it and connecting a DMM to the output and ground), so I turned on my digital camera. The IR LED was occasionally flickering or it went on the faded away. Later, when I came back to do some more testing, the IR LED just won't turn on at all. It hasn't turned on since. :-[

Is it possible that both sensors are dead :'(? (I tested both.) If that's the case, I just lost $26 dollars.
Maybe I'm doing something wrong (lets hope so). I did look through the data sheets (http://www.robotshop.ca/PDF/sharp-gp2d15-datasheet.pdf).

 I would appreciate your input.

Canabots

« Last Edit: November 27, 2008, 09:06:10 PM by Canabots »
My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: SHARP IR GP2D15 is Not Turning on
« Reply #1 on: November 27, 2008, 07:57:47 AM »
ok do this test
Power up the Sharp IR(give it 5V on red wire and GND on black wire) and leave the Signal wire unconnected
Take your camera and look directly into the sensor and see if its on

Tell me you results from that test and we can go on
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
Re: SHARP IR GP2D15 is Not Turning on
« Reply #2 on: November 27, 2008, 05:39:06 PM »
Already ahead.

Quote
ok do this test
Power up the Sharp IR(give it 5V on red wire and GND on black wire) and leave the Signal wire unconnected
Take your camera and look directly into the sensor and see if its on

That was part of my initial test (I probably should have said that in the first post, sorry :-[ my bad). Unfortunately, it yielded no positive results.


Thanks for the fast response.

Canabots
« Last Edit: November 27, 2008, 07:13:16 PM by Canabots »
My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: SHARP IR GP2D15 is Not Turning on
« Reply #3 on: November 27, 2008, 05:55:59 PM »
are you sure you are giving it 5V ? Take a multimeter and double check.
Also check if the connector is plugged in to the Sharp IR and nothing is shorting.
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
Re: SHARP IR GP2D15 is Not Turning on
« Reply #4 on: November 27, 2008, 07:17:43 PM »
The results to that test are as follows:

- No shorts
- 4.5-5V coming from the regulator (the sensor can handle 3-5V according to the datasheet)
- Positive is with positive, GND with Ground

ALSO: I decided to look through the camera during that test again. Does it matter what angle it is viewing from? Because when it flickered, it was because it was moving a bit. The contradictory point is that when it was stationary, and the camera is looking directly at it, it didn't light. Hmmm...


My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: SHARP IR GP2D15 is Not Turning on
« Reply #5 on: November 27, 2008, 07:40:54 PM »
maybe bad connecton inside the sensor connecting the LED - though thats highly unlikely

Perhaps you gave it too high voltage once and it killed the IR LED?
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
Re: SHARP IR GP2D15 is Not Turning on
« Reply #6 on: November 27, 2008, 07:48:07 PM »
Hmmmmm...

I don't think the IR LEDs are burnt out 'cause of high voltage, since they still will flicker/go on for a bit.

It IS possible that there might be a loose connector since the wires can move a little inside the casing of the connector. But the connection feels solid as I plug it in.

I'll keep trying out different camera angles and the movement of the sensor and see what happens.
My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: SHARP IR GP2D15 is Not Turning on
« Reply #7 on: November 27, 2008, 08:11:25 PM »
maybe try a different camera
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
Re: SHARP IR GP2D15 is Not Turning on
« Reply #8 on: November 27, 2008, 08:21:22 PM »
Ok, so I tested with a different camera...

       ...AND IT WAS A SUCCESS!!! :D

Used my webcam this time. I find it odd that my 1.3MP built-in laptop webcam detects IR light better my digital camera. Perhaps there's some diference in viewing angle.

Anyway, now that that's settled, I'll try testing the output again and see what's the deal about that.

Thanks,

Canabots
« Last Edit: November 27, 2008, 08:36:27 PM by Canabots »
My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: SHARP IR GP2D15 is Not Turning on
« Reply #9 on: November 27, 2008, 08:35:16 PM »
Happy that I helped .  ;D
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
Re: SHARP IR GP2D15 is Not Turning on
« Reply #10 on: November 27, 2008, 09:03:26 PM »
So I looked at the datasheets again. Turns out in the block diagram, the has to be a 12Kohm resistor connected from the output to the 5V power supply. Since I don't have any 12K resistors on me at the moment, I used a 47 Kohm one instead.

Put simply, I am proud to say it now displays a digital output on my DMM. :D

High is 4.3V, Low is .14-.16V.

Thank you so much for all the help you've given me today airman00! ;D It is all very much appreciated and I am very grateful for it.

Canabots

(PS: I did a few more tests between digital and Web cameras. It actually appears that webcams have better viewing angles than Digital

cameras, but this probably depends on which one you use and the settings set at the time.)
My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

 


Get Your Ad Here

data_list