Author Topic: Dumb question on 5V versus 3.3 Volt devices and AXON  (Read 2335 times)

0 Members and 1 Guest are viewing this topic.

Offline DscrimagerTopic starter

  • Full Member
  • ***
  • Posts: 57
  • Helpful? 0
Dumb question on 5V versus 3.3 Volt devices and AXON
« on: December 06, 2008, 12:03:34 PM »
I want to interface an ADXL330 triple axis accelerometer to my AXON for my 'bot.

Now my question is, as long as I power this board from the 3.3V source on the AXON I can still sample the accelerometer ouput pins with the regular AXON ADC pins correct? I would just see values that are from 0 - 3.3 Volts versus going up to 5 volts?

I did a little searching but didn't find anything about this....

Doug


Offline DscrimagerTopic starter

  • Full Member
  • ***
  • Posts: 57
  • Helpful? 0
Re: Dumb question on 5V versus 3.3 Volt devices and AXON
« Reply #1 on: December 06, 2008, 01:47:13 PM »
I just found the answer in the header files... basically what I thought was true...power from 3.3 header and read from normal ADC pin,...

Doug

Offline pomprocker

  • Supreme Robot
  • *****
  • Posts: 1,430
  • Helpful? 16
  • Sorry miss, I was giving myself an oil-job.
Re: Dumb question on 5V versus 3.3 Volt devices and AXON
« Reply #2 on: December 07, 2008, 01:53:29 AM »
I don't think you can use 3.3v to power the Axon when it is running at 16MHz

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: Dumb question on 5V versus 3.3 Volt devices and AXON
« Reply #3 on: December 07, 2008, 03:25:46 AM »
Dscrimager, yeap you are correct.

pomprocker, he means the 3.3V output on the Axon ;D

This device also uses the ADXL330, just in case you wanted something off the shelf:
http://www.dimensionengineering.com/DE-ACCM3D.htm

 


Get Your Ad Here