go_away

Author Topic: axon usb not recognized in xp anymore  (Read 4205 times)

0 Members and 1 Guest are viewing this topic.

Offline yerbieTopic starter

  • Full Member
  • ***
  • Posts: 62
  • Helpful? 3
axon usb not recognized in xp anymore
« on: January 09, 2009, 09:03:50 PM »
I've been playing with my new axon for the past few days and it's been working great.  All the sudden today, when I plugged in my usb to program the device, it did not detect it  :'(.  I turned on the battery and xp says that the usb device is not recognized.  Nothing has changed. 

I tried to reinstall the drivers, but the same issue.  I also tried on another computer (vista), and it also did not work.  Any help/advice would greatly be appreciated.  The last program that i burned on there is still working, so I know I didnt fry anything.

I followed these steps: http://www.societyofrobots.com/axon/axon_getting_started_hardware.shtml
I also dont have a programmer, so I depend on the fboot.

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: axon usb not recognized in xp anymore
« Reply #1 on: January 09, 2009, 10:26:57 PM »
a quote from your IM:
Quote
I figured out the problem to be a loose usb connector on the axon.  I have to hold it and wiggle it around before it detects.  Do you have any recommendations?

This means that a pin on the USB connector is loose - this is basically called a ghost short/connection as it only sometimes works. These are insanely hard to debug so I'm glad you found the problem.

Basically get out a fine tipped soldering iron and go over the 5 pins on the USB connector. Make sure you have good lighting and a steady hand as the traces are really tiny. Take your time - you don't want to accidentally short the traces with solder. If you have questionable eyesight, use a magnifying glass to verify you didn't short any traces. 3x optical is ok but 10x is better.

If you recently bought your Axon in the last 2 months it uses lead-less solder. You'll need an extra hot iron, like 35W+, and .01" or .02" solder if you want to add extra solder (probably not needed).

Offline yerbieTopic starter

  • Full Member
  • ***
  • Posts: 62
  • Helpful? 3
Re: axon usb not recognized in xp anymore
« Reply #2 on: January 09, 2009, 10:55:39 PM »
I just did a continuity test and looks like 2 the last pins on the left might be shorted.  i'm going to try to fix it, but i thought since i just got this board (3 days ago), you might fix it for me since it's a manufacture issue

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: axon usb not recognized in xp anymore
« Reply #3 on: January 09, 2009, 11:43:54 PM »
Quote
I just did a continuity test and looks like 2 the last pins on the left might be shorted.
Those two left pins are supposed to be shorted. It's probably one of the other three that are a bit loose. You probably won't find anything wrong by using a multimeter - touching a pin will probably cause it to connect properly.

If you have a soldering iron its like a 10 second fix for free. I'm going to reserve replacement as a last option as it'll cost me in shipping and you'll have to wait like ~2 weeks to get a new one.

Offline yerbieTopic starter

  • Full Member
  • ***
  • Posts: 62
  • Helpful? 3
Re: axon usb not recognized in xp anymore
« Reply #4 on: January 10, 2009, 04:54:36 AM »
wow, i have to say, that was pretty intense.  i never had to solder pins that close together before, but you were right.  I guess there was some cold solder connection points.  after about 15 sec of heating it up and getting it shiny again, i connected the usb and voila! it detected. ;D ;D

thanks admin for helping me through this

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: axon usb not recognized in xp anymore
« Reply #5 on: January 10, 2009, 08:19:20 AM »
Good to hear :)

But if you want intense, try soldering the entire Axon by hand! I messed up quite a few prototypes!

Offline frodo

  • Supreme Robot
  • *****
  • Posts: 329
  • Helpful? 2
  • BOW DOWN TO MY MIGHTY STARE!!
Re: axon usb not recognized in xp anymore
« Reply #6 on: January 10, 2009, 04:30:46 PM »
bet it took a lot of time, soldering axons by hand. lol. how do you it now? manafacturing robots?
OMG!!!! I AM SUPREME ROBOT!!!

Check out my Web

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: axon usb not recognized in xp anymore
« Reply #7 on: January 10, 2009, 08:55:58 PM »
Soldering a single Axon by hand is a ~4 hour process that requires special tools . . . I use manufacturing robots now ;D

Offline SmAsH

  • Supreme Robot
  • *****
  • Posts: 3,959
  • Helpful? 75
  • SoR's Locale Electronics Nut.
Re: axon usb not recognized in xp anymore
« Reply #8 on: January 12, 2009, 04:38:07 PM »
yea just sorta offload the work on the robots and go have a beer
Howdy

Offline Its_Friday

  • Jr. Member
  • **
  • Posts: 31
  • Helpful? 0
Re: axon usb not recognized in xp anymore
« Reply #9 on: April 11, 2009, 11:12:15 PM »
I have a very similar problem to yerbie. Expect i doubt my axon usb connector is loose :(
And my presentation is in 2 days -.-

Alright, i went through and checked every pin in the usb cable nothing wrong. I hooked up the cable to the axon microcontroller, and then check all 4 pins. Electricity is flowing through all pins! (positive negative data+ data-) and yet it does not work.
« Last Edit: April 11, 2009, 11:34:02 PM by Its_Friday »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: axon usb not recognized in xp anymore
« Reply #10 on: April 12, 2009, 03:27:30 AM »
I have a very similar problem to yerbie. Expect i doubt my axon usb connector is loose :(
And my presentation is in 2 days -.-

Alright, i went through and checked every pin in the usb cable nothing wrong. I hooked up the cable to the axon microcontroller, and then check all 4 pins. Electricity is flowing through all pins! (positive negative data+ data-) and yet it does not work.
How do you know it doesn't work? I mean, what error you get? Did you try restarting your PC? Does your PC detect the Axon? Did it work at first then stop working? What do you have connected to your Axon?

Oh, and you may need a backup plan for your presentation, there is no way I can send you a new Axon in that time . . . if you can get a hardware ISP programmer (email everyone you know), then you can program the Axon just in time I hope!
« Last Edit: April 12, 2009, 03:30:39 AM by Admin »

Offline Its_Friday

  • Jr. Member
  • **
  • Posts: 31
  • Helpful? 0
Re: axon usb not recognized in xp anymore
« Reply #11 on: April 12, 2009, 05:56:58 AM »
The error that i get when i plug in the axon is "USB device not recognized. Once of the USB devices attached to this computer has malfunction, and windows does not recognize it." I get this error on 2 separate computers. I've uploaded programs to the axon several times before w/o this problem had occurred. Nothing about the computers i use to upload programs have changed. I even updated the drivers and it still doesn't work:(

Unfortunately i don't know anyone personally that is into robots, so i doubt i can find an ISP programmer and there are essentially no hobby shops of this sort in proximity D:

When i plug in the axon via usb mini-b, nothing else is plugged into the axon microcontroller.
« Last Edit: April 12, 2009, 06:05:35 AM by Its_Friday »

Offline dellagd

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 731
  • Helpful? 5
  • Come to the dark side... We have cookies!
Re: axon usb not recognized in xp anymore
« Reply #12 on: April 12, 2009, 02:13:36 PM »
Unfortunately i don't know anyone personally that is into robots, so i doubt i can find an ISP programmer and there are essentially no hobby shops of this sort in proximity D:

being a roboticy person is a hard life. usually no one you know is into robotics like you.  :'(
Innovation is a product of Failure, which leads to Success.

If I helped, +1 helpful pls

I Won!
3rd place! I'm taking $100

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: axon usb not recognized in xp anymore
« Reply #13 on: April 12, 2009, 11:19:14 PM »
Its_Friday, what did you connect to your Axon? Did you use the 3.3V power output?

Offline Its_Friday

  • Jr. Member
  • **
  • Posts: 31
  • Helpful? 0
Re: axon usb not recognized in xp anymore
« Reply #14 on: April 13, 2009, 05:59:40 AM »
i connected my axon to 2 photosensors and 2 motors. And no, i did not use the 3.3V power output.

Offline SmAsH

  • Supreme Robot
  • *****
  • Posts: 3,959
  • Helpful? 75
  • SoR's Locale Electronics Nut.
Re: axon usb not recognized in xp anymore
« Reply #15 on: April 13, 2009, 06:17:58 AM »
by motors do you mean dc motors? servos? motor controllers and dc motors?
Howdy

Offline Its_Friday

  • Jr. Member
  • **
  • Posts: 31
  • Helpful? 0
Re: axon usb not recognized in xp anymore
« Reply #16 on: April 13, 2009, 07:51:00 AM »
12 v DC motors 300 mA

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,660
  • Helpful? 169
    • Society of Robots
Re: axon usb not recognized in xp anymore
« Reply #17 on: April 13, 2009, 08:28:42 AM »
Just an FYI to everyone, I sent Its_Friday an email to handle the problem.

 


Get Your Ad Here