Author Topic: Member Tutorials - how do you guys embed your youtube vids?  (Read 3320 times)

0 Members and 1 Guest are viewing this topic.

Offline BangarangTopic starter

  • Contest Winner
  • Jr. Member
  • ****
  • Posts: 9
  • Helpful? 0
Member Tutorials - how do you guys embed your youtube vids?
« on: January 25, 2009, 03:35:53 PM »
I've been messing around with this for a while now and nothing seems to work.  I've followed the instructions listed at another thread here:
http://www.societyofrobots.com/member_tutorials/node/99

All I am getitng is a blank image square.  When I remove a "<" or add a ">" here of there as I am tweaking I can get the vid embeded on my screen but nothing comes up on the preview and the HTML editor will not allow me to save and close.

What am I missing?


Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #1 on: January 25, 2009, 08:07:05 PM »
Thats for the member tutorials area, not the forums area...

In the youtube link, copy all the characters after the "=" sign and put them between [youtube]{/youtube]
United States Marine Corps
Infantry
Returns to society: 2014JAN11

Offline BangarangTopic starter

  • Contest Winner
  • Jr. Member
  • ****
  • Posts: 9
  • Helpful? 0
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #2 on: January 25, 2009, 08:47:48 PM »
Thats for the member tutorials area, not the forums area...

In the youtube link, copy all the characters after the "=" sign and put them between [youtube]{/youtube]


Yes but is there a forums for the members tutorials area?

anyway, did you mean to copy all characters after the "=" sign following "width" , or the "=" sign following "value" ?
several = signs there in the youtube link.

neither seems to work.
heres the link for refrence:
<object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/ETMPsOxfQE8&hl=en&fs=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/ETMPsOxfQE8&hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #4 on: January 26, 2009, 04:10:02 PM »
Eric thats the tutorial that caused all this trouble.

bangarang. Completely ignore every that tutorial has told you.


take: Yz2gdgIUwdE and put it between the youtube brackets and you get
[youtube]Yz2gdgIUwdE[/youtube]


-EDIT-
ermm... why isnt it working...
« Last Edit: January 26, 2009, 04:28:50 PM by HDL_CinC_Dragon »
United States Marine Corps
Infantry
Returns to society: 2014JAN11

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,653
  • Helpful? 21
  • narobo.com
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #5 on: January 26, 2009, 04:13:56 PM »
-EDIT-
ermm... why isnt it working...

you mean...
[youtube]
RqhLbR6A9g4[/youtube]

By member tutorial, you have to press the HTML button to edit the HTML code of the tutorial and then add in the "embedded code" of your youtube video.
Check out the Roboduino, Arduino-compatible board!


Link: http://curiousinventor.com/kits/roboduino

www.Narobo.com

Offline HDL_CinC_Dragon

  • Supreme Robot
  • *****
  • Posts: 1,261
  • Helpful? 5
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #6 on: January 26, 2009, 04:29:51 PM »
I was assuming he was trying to get vids in the forum.

I got it working though. I wasnt paying close enough attention to why it was failing. I can be pretty dumb sometimes.
« Last Edit: January 26, 2009, 04:31:05 PM by HDL_CinC_Dragon »
United States Marine Corps
Infantry
Returns to society: 2014JAN11

Offline BangarangTopic starter

  • Contest Winner
  • Jr. Member
  • ****
  • Posts: 9
  • Helpful? 0
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #7 on: January 26, 2009, 07:59:39 PM »
yes.

i am trying to imbed the video on my TUTORIAL. (not the forums)
i have tried the information in the "how to" link, as stated in the first post.

i am using the html edit window,  but it won't let me save.  when it does,  all i get is the blank box.

if i missed something, can someone spell it out step by step what i am supposed to do?


ps.
i should also mention there is no "modify" or "edit" option in the contest thread:
http://www.societyofrobots.com/robotforum/index.php?topic=5722.0
How am I supposed to update my entry post or place a link there to the tutorial?
« Last Edit: January 26, 2009, 08:13:00 PM by Bangarang »

Offline BangarangTopic starter

  • Contest Winner
  • Jr. Member
  • ****
  • Posts: 9
  • Helpful? 0
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #8 on: January 27, 2009, 05:29:11 PM »
sorry to bump this, but i gotta get my member page up for the contest.
lets try a new tact:
Could someone who has a member page with an embedded youtube video please copy the html code exactly as it shows how you pasted the imbed link from the youtube page and then paste it here in this thread?

It might help if you include the line above and below the actual youtube pasted code for refrence.

Many Thanks!

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,657
  • Helpful? 169
    • Society of Robots
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #9 on: February 04, 2009, 09:12:12 PM »
Here is html from here:
http://www.societyofrobots.com/member_tutorials/node/59

Code: [Select]
<p>
<title>Line follower, obstacle avoider, photovore and photophobe in 40$</title>
<!--break--></p>
<h1>Overview</h1>
<p> </p>
<p align="center"><img src="http://i305.photobucket.com/albums/nn236/pratheekn/IMG_2639.jpg" width="328" height="218" />  </p>
<p align="center"> </p>
<p>
<br />
This tutorial details the construction of a simple and low cost robot. The robot is mainly a line follower but can also be used as a photovore, a photophobe, and obstacle avoider!And all this for less than 40$. The best part is that the robot does not use any microcontroller, which means you need no expensive programmer or even a computer to program your robot. This tutorial is mainly aimed at beginners, hence I have tried to keep the robot as simple and cheap as possible. With only a few parts you can get this robot up and going.
Here is a video of the robot following black line.
</p>
<p> </p>
<center>
<object height="350" width="425">
<param name="movie" value="http://www.youtube.com/v/Wn-reuG7Irs" />  <embed src="http://www.youtube.com/v/Wn-reuG7Irs" type="application/x-shockwave-flash" height="350" width="425"></embed> 
</object>
</center>
<h3>Specifications and Features  </h3>
<p>
The sensor used are four LDRs and LEDs.<br />
The steering method used here is differential drive.<br />
The actuators used are two 100 rpm DC motors.<br />
One 9V battery provides power to the robot.<br />
The robot can follow a dark line on a light surface or a
        light line on a dark surface. <br />
A LED is switched on when the robot is on the line (this   
        makes things easier during debugging).<br />
It can also be used as a photovore, photophobe, and 
        obstacle avoider.</p>

Offline paulstreats

  • Supreme Robot
  • *****
  • Posts: 1,381
  • Helpful? 21
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #10 on: March 08, 2009, 05:19:31 PM »
Im also having this problem, whenever you put the embed code into the html editor and click update, a javascript error occurs saying it doesnt support this property or method (click on the error icon and it will say which file the error occurs in ).

Once you click update the html editor doesnt disappear - it does embed the video into the normal editor but when you click to update the page it just disappears again.

There is a problem with this

---------

There is also no button to change the text size. I know this can be done through HTML but if theres an option to change text color I would imagine that there is supposed to be an option to change size
« Last Edit: March 08, 2009, 08:00:20 PM by paulstreats »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,657
  • Helpful? 169
    • Society of Robots
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #11 on: March 26, 2009, 05:14:22 AM »
Hmmm I am unable to replicate the problem . . .

Quote
Once you click update the html editor doesnt disappear - it does embed the video into the normal editor but when you click to update the page it just disappears again.
You lost me on this . . . can you reword it?

Offline paulstreats

  • Supreme Robot
  • *****
  • Posts: 1,381
  • Helpful? 21
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #12 on: March 26, 2009, 06:45:03 PM »
1) I click the EDIT HTML button which brings up a seperate page where you can edit the html.

2) Go to youtube and copy the embedding code

3) paste it into the html window

4) click the update button.
(usually when the update button is pressed, the html window closes and updates the main editor. It only works wrongly when I try embedding youtube videos).

what happens when I click the update button with youtube embed code is the html editor stays open and throws a javascript error in main editor window. The youtube video does actually appear in the editor window but when you submit the tutorial page the video and the embed code disappears again leaving no video on the page. Go back into edit mode and the youtube embed code has also disappeared.

I have tried it with many varieties of embedding and none seem to work(including the embed code from the example you posted in this thread).

the main page contains a general "object doesnt support this property or method" error
Also if you cancel or close the html editor with the (x) and try to re open it, it opens but with no text in it.
« Last Edit: March 26, 2009, 06:46:41 PM by paulstreats »

Offline Ro-Bot-X

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 1,431
  • Helpful? 25
  • Store: RoBotXDesigns.ca
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #13 on: March 27, 2009, 05:50:20 AM »
Same thing happened to me when I wrote my last tutorial. I could post the video from youtube in the forum, but not in the tutorial. Same javascript error as Paul describes. I just gave up trying an linked the video.
Check out the uBotino robot controller!

Offline voyager2

  • Supreme Robot
  • *****
  • Posts: 459
  • Helpful? 6
  • Behold! The Impossible Triangle of robotics!
Re: Member Tutorials - how do you guys embed your youtube vids?
« Reply #14 on: June 07, 2010, 11:34:40 PM »
I found the easiest way to insert YouTube is to just paste in the full URL
Like this:
]Small robot fish powered by solid polymer fuel cell : DigInfo[/url]

Works like a charm
And Admin said "Let there be robots!"
And it was good.

 


Get Your Ad Here

data_list