go_away

Author Topic: Axon just keeps on restarting (tried different power-solutions..)  (Read 4160 times)

0 Members and 1 Guest are viewing this topic.

Offline TomasTopic starter

  • Full Member
  • ***
  • Posts: 111
  • Helpful? 0
I have currently connected three sharp ir GP2Y0A21YK sensors, one servo and one motor controller.

With just one sharp ir sensor connected, everything works well. But when I connect two or more, the axon just starts restarting at pretty short intervals (varies from 1 to 5 seconds, mostly).

I've tried one 1500 MAh 7.2 volts battery, one 2500 MAh 7.2 volts battery and Ive tried a pretty good voltage supplier. I've tried the batteries parallell-coupled. The axon just keeps on resetting with two or more sharp ir sensors connected. What could be the problem? Im currently using 1.01 of the axon source code, I will upgrade to 1.05 within the day. But I couldnt see why this would do this?

Any batteries recommended for my use? Perhaps a battery just for the sharp irs would be good?

Offline Razor Concepts

  • Supreme Robot
  • *****
  • Posts: 1,856
  • Helpful? 53
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #1 on: January 29, 2009, 04:15:19 AM »
Does your code have some kind of delay in it? I was just messing around with a method like this
Code: [Select]
void control(void)
{
dostuff();
control();
}
And found that it kept on resetting because it was going too fast or something, so I just added a 10ms delay in there and it worked.

Offline TomasTopic starter

  • Full Member
  • ***
  • Posts: 111
  • Helpful? 0
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #2 on: January 29, 2009, 05:02:34 AM »
No, I got several delays.

But I found this topic, a guy with exactly the same problem.
http://www.societyofrobots.com/robotforum/index.php?topic=5190.0

Solution: Hook up a small condensator to the + and - poles of the sharp connector. I used a 22 uF condensator, worked great. Totally stable now :) And the results from the axon is much better now, finally getting good readings.

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,657
  • Helpful? 169
    • Society of Robots
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #3 on: January 29, 2009, 08:14:57 PM »
Well call them capacitors over here :P

Out of curiosity, what else did you have connected to the Axon? I haven't had a Sharp IR reset my Axon before!

Offline TomasTopic starter

  • Full Member
  • ***
  • Posts: 111
  • Helpful? 0
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #4 on: February 01, 2009, 02:47:28 PM »
Capacitators then.

I had three sharp IR's, one motor controller, one radio reciever and one servo.

(And about the "double posting". I only posted the solution to my problem so others that search the forums may get answers to their question without creating a new topic).

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,657
  • Helpful? 169
    • Society of Robots
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #5 on: February 01, 2009, 11:10:35 PM »
I had three sharp IR's, one motor controller, one radio reciever and one servo.
Are you powering the motor controller directly from the Axon by any chance?

Sharp IR's are very noisy and I'm starting to wonder if three overwhelmed the ceramic capacitors on the Axon :-\

Is it possible for you to run the Axon with the three Sharp IRs and no caps and tell me if the resets still happen? I only brought one with me to Bangkok . . .

Offline TomasTopic starter

  • Full Member
  • ***
  • Posts: 111
  • Helpful? 0
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #6 on: February 02, 2009, 05:40:05 AM »
I ran it using three sharp ir sensors and nothing else, still resetted.

Edit: The motor controller is not powered by the axon. It only recieves PWM signals from it, and uses power directly from the battery to power the motor.
« Last Edit: February 02, 2009, 05:41:18 AM by Tomas »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,657
  • Helpful? 169
    • Society of Robots
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #7 on: February 02, 2009, 07:05:01 AM »
I decided to make this an Axon FAQ question:
http://www.societyofrobots.com/axon/axon_FAQ.shtml#sharp_ir_reset

Offline TomasTopic starter

  • Full Member
  • ***
  • Posts: 111
  • Helpful? 0
Re: Axon just keeps on restarting (tried different power-solutions..)
« Reply #8 on: February 02, 2009, 08:09:48 AM »
I just tested it, it is also unstable using only two ir sensors. But a small capacitator makes it much, much better.

 


Get Your Ad Here