Author Topic: snake robots / added YouTube embedded feature (new!)  (Read 7466 times)

0 Members and 1 Guest are viewing this topic.

Offline AdminTopic starter

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,663
  • Helpful? 169
    • Society of Robots
snake robots / added YouTube embedded feature (new!)
« on: March 02, 2007, 10:30:42 PM »
You havnt seen snake robots until you have seen this video!

[youtube=425,350]4cAwzSZqO_w[/youtube]

I like how the guy totally freaks out :P

btw, I added youtube embedding features to the forum - enjoy!
just click the youtube button, and put the jumbled letters and numbers between the brackets.

for example, if you wanted to embed this video:

then you want to put 4cAwzSZqO_w between the youtube brackets

Offline AdminTopic starter

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,663
  • Helpful? 169
    • Society of Robots
Re: snake robots / added YouTube embedded feature (new!)
« Reply #1 on: March 02, 2007, 10:37:10 PM »
and two more videos of the snake robot:

[youtube=425,350]x3JQvoxTBVU[/youtube]

Im really impressed on how it cant balance itself like that. I also wonder how the remote control can do such complex actions . . . It just doesnt look preprogrammed at all . . .

this is an older video i showed in a previous post:

[youtube=425,350]k-VgI4wNyTo[/youtube]

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #2 on: March 03, 2007, 09:35:31 AM »
Very slick robot, as is the underwater one.  I love robots like that.

As for the youtube embedding, cool... though it doesn't seem to work too well when I want to view it... :(
The LED Massacre continues.  Death count is now 5

Offline AdminTopic starter

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,663
  • Helpful? 169
    • Society of Robots
Re: snake robots / added YouTube embedded feature (new!)
« Reply #3 on: March 03, 2007, 09:41:28 AM »
Quote
though it doesn't seem to work too well when I want to view it...
hmmmmm its working fine on my end . . . can you explain the problem? ive only tested it on IE so far . . .

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #4 on: March 03, 2007, 11:41:31 AM »
Well, I use firefox if that makes any difference.  The only problems so far have been with ones in this thread.  The one you posted in another thread worked fine.  The first two in this thread took a fair amount of clicking before anything happened.  The last one, well thus far no amount of clicking made it work for me.  It's as if it's an image, and not a video or a link.

Now I'm not sure how the embedding is supposed to work, but when it does work for me it opens up a new window to the youtube page.  When it doesn't, nothing happens.  I can right-click on it and get most of the menu for a typical flash movie, except play.

It's possible that my firefox just doesn't have the right plugin for the movies, and so it thinks they are flash movies... though that wouldn't account for the unpredictable nature of the error....  :-\
The LED Massacre continues.  Death count is now 5

Offline AdminTopic starter

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,663
  • Helpful? 169
    • Society of Robots
Re: snake robots / added YouTube embedded feature (new!)
« Reply #5 on: March 03, 2007, 12:26:00 PM »
well, ive found youtube itself to be buggy . . . since ive started using it for this site ive run into numerous problems . . . ever noticed how some of my videos are using google video? its because i couldnt fix the weird youtube bugs . . . ill add google embedded video to the forum when i get the time . . . .

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #6 on: March 03, 2007, 02:57:45 PM »
Cool, though I'll see if there's anything I can do on my end.
The LED Massacre continues.  Death count is now 5

Offline dunk

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 1,086
  • Helpful? 21
Re: snake robots / added YouTube embedded feature (new!)
« Reply #7 on: March 03, 2007, 04:20:21 PM »
i'm using firefox and it works fine for me.
i don't think it's your firefox plugins as it works for you on other threads.

i suspect it's an internet bandwidth problem which will be largely outwith your controll (unless you're thinking of changing your isp).
try waiting a while and see if the internet weather is any better.

it could also be a problem at youtube. they only have a limited number of servers and loads of users..
again, try waiting a while and retrying.

dunk.

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #8 on: March 03, 2007, 09:46:44 PM »
It's not my bandwidth, as everything else loads perfectly fine.  Even if I go to youtube itself, all of the videos load perfeclty.  It's only when I click on these links that things don't go.  The last one in this thread is the worst.  I click on it, it says "read from ...." in the status bar, but absolutely nothing happens.  Firefox doesn't attempt to load anything, and doesn't go anywhere.....


But maybe..... hmm... must try something....


Nope.  Thought it might be my virus scanner, but disabling it did nothing.
« Last Edit: March 03, 2007, 09:48:30 PM by Sam_Charette »
The LED Massacre continues.  Death count is now 5

Offline dunk

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 1,086
  • Helpful? 21
Re: snake robots / added YouTube embedded feature (new!)
« Reply #9 on: March 04, 2007, 06:34:47 AM »
Quote
It's not my bandwidth, as everything else loads perfectly fine.

ah but it's more subtle than that.
even though you can connect to your ISP fine there is no guarantee that your ISP has a reliable route to the datacenter youtube are serving that video out of.
if you are interested you could try running some traceroutes to youtube.com
instructions here:http://usertools.plus.net/tutorials/id/34
this will show you the various hops your connection goes through to get to youtube.
the won't really help you any but worth looking at if you are interested in how the internet works.

a traceroute will also only tell you what happens as far as the youtube Border Routers.
inside the BRs i'd imagine a traceroute's UDP datagrams will be routed differently to whatever protocol/port the flash plugin is using.

here's what i'm seeing:
Code: [Select]
                                          My traceroute  [v0.69]
lappy (0.0.0.0)(tos=0x0 psize=64 bitpattern=0x00)                                 Sun Mar  4 12:32:10 2007
Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                                                  Packets               Pings
 Host                                                           Loss%   Snt   Last   Avg  Best  Wrst StDev
 1.                                                              0.0%    19    2.6   2.7   2.6   3.3   0.2
 2. d-deg-edge1.magnet.ie                                        0.0%    19   13.2  14.1  11.3  44.5   7.4
 3. d-deg-core1b.magnet.ie                                       0.0%    18   13.5  12.6  11.6  15.9   1.0
 4. d-deg-edge2.magnet.ie                                        0.0%    18   92.4  35.9  12.2 346.3  79.7
 5. 208.50.25.109                                                0.0%    18   22.7  30.9  21.9 118.1  24.3
 6. pos7-0-0.10g.ar2.dca3.gblx.net                               0.0%    18   96.5  96.1  93.9 100.6   1.6
 7. 67.17.198.74                                                 0.0%    18   97.3 127.4  94.1 261.9  56.5
 8. 64.15.118.6                                                  0.0%    18   93.9 112.2  93.9 169.2  27.1
 9. ???
10. 64.15.116.5                                                  0.0%    18  117.4 117.1 115.1 118.8   1.1
11. ???
12. ???
13. youtube.com                                                  0.0%    18  164.5 165.5 163.5 167.1   1.2

anyway,
i'm off topic again.
yes. it could be a problem with your computer setup. (unlikely though as some of the links work for you.)
it could be a problem with the internet.
it could be a problem at youtube.
i think it's fairly unlikely it's a problem with Admin's setup.

how's everyone else getting on with the embedded youtube links?
if it's a wide spread problem i could look into it further.

dunk.

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #10 on: March 04, 2007, 09:32:21 AM »
Quote from: sam_charette
It's not my bandwidth, as everything else loads perfectly fine.
ah but it's more subtle than that.
Quote from: sam_charette
Even if I go to youtube itself, all of the videos load perfeclty.

No, it really isn't any more subtle than that :)

I have zero problems getting to youtube.  It's only when I click on the links here that nothing happens.  I don't mean that it tries to connect, you see the little ring in the top right animating showing that it's going, you see the progress bar moving, it says it's going somewhere.... Nothing happens at all.  It's as if firefox doesn't recognize it as something it can do something with.  IE, however, sees it fine, and I can get the videos to run as intended without a problem.

The likeliest scenario is that there's something up with my firefox browser, if it's working for others.
The LED Massacre continues.  Death count is now 5

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #11 on: March 04, 2007, 09:33:44 AM »
As an addendum, I don't know what I was smoking earlier, but it seems that none of them were working in firefox now, though IE and youtube still work fine.
The LED Massacre continues.  Death count is now 5

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #12 on: March 04, 2007, 10:08:42 AM »
And now for something REALLY strange...

If I move my mouse and click on the link while moving, and make sure to do so as early as possible when entering the image, then firefox will open a new window at the page for that video on youtube where the video runs fine.  If I just move onto the image and click, nothing happens.  I have to move and click quickly, then it brings me there and the video works.

I think that it's safe to say that it's my computer. :D
The LED Massacre continues.  Death count is now 5

Offline dunk

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 1,086
  • Helpful? 21
Re: snake robots / added YouTube embedded feature (new!)
« Reply #13 on: March 04, 2007, 11:46:33 AM »
ok, if none of them work in firefox then yes, it is probably a brouser problem.
the fact it works in IE confirms this.
i was working under the assumption that some clips were working but not others.

what version of firefox you running?
i have no problems firefox 1.5 and flashplayer 9.0 under Linux.

dunk.

Offline Sam_Charette

  • Jr. Member
  • **
  • Posts: 45
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #14 on: March 04, 2007, 02:33:51 PM »
1.5.0.10 is the version of FF that I am running with the latest flash version.
The LED Massacre continues.  Death count is now 5

Offline dunk

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 1,086
  • Helpful? 21
Re: snake robots / added YouTube embedded feature (new!)
« Reply #15 on: March 04, 2007, 05:11:44 PM »
so, anyone else reading this using the same combonation?
and if so do you have the same problems?

it would be worth filing bug reports with firefox and adobe if you can find someone else with the same issue to reproduce the problem.

dunk.

Offline Brandon121233

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 320
  • Helpful? 0
  • "Genius is %1 inspiration and %99 perspiration"
Re: snake robots / added YouTube embedded feature (new!)
« Reply #16 on: March 13, 2007, 05:14:43 PM »
Yeah im having the same exact problem as sam c, I also have firefox 1.5.0.10 but I just use a firefox plugin called IE tab which lets me quickly switch any page I'm viewing in firefox, and change it so its IE explorer, inside of firefox- its pretty neat and saves time
Hell, there are no rules here—we're
   trying to accomplish something.

                                                                              —Thomas Edison

Offline azy

  • Full Member
  • ***
  • Posts: 107
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #17 on: November 14, 2010, 05:22:04 AM »
Some close up shots , better vid quality. This is 1 of my 10 ten bots

Amphibious Robot Snake
« Last Edit: November 14, 2010, 05:23:36 AM by azy »

Offline azy

  • Full Member
  • ***
  • Posts: 107
  • Helpful? 0
Re: snake robots / added YouTube embedded feature (new!)
« Reply #18 on: November 23, 2010, 07:14:29 PM »
Ok its an inchworm not a snake, but it uses muscle wire & is pretty cool (muscle wire shrinks when heated by electricity)

Inchworm robot with muscle-wire

 


Get Your Ad Here

data_list