go_away

Author Topic: Broken axon or maybe broken compiler? :(  (Read 1287 times)

0 Members and 1 Guest are viewing this topic.

Offline TomasTopic starter

  • Full Member
  • ***
  • Posts: 111
  • Helpful? 0
Broken axon or maybe broken compiler? :(
« on: February 09, 2009, 03:59:52 AM »
Hi. Im having problems with the axon. It just sends tons of gibberish to terminal and resets constantly.

I had a pretty big program on it, but now Im just using the different source codes and inside the axon function, a simple rprint("\r\nTest");

So I got just clean source code (nothing fancy, nothing extra) and the axon just resets. I've tried several different batteries and powersupply units, but no one makes any difference. I do think I have a AVR programmer here, could it be that the program on the axon is somehow corrupt? I've never used a programmer before, so I dont even know how to go forward with it (one of my friends here got the programmer, not me).


I have not been messing with anything else than hooking up sensors, servos and motorcontrollers, and of course, writing source code to it.


So I wrote the post http://www.societyofrobots.com/robotforum/index.php?topic=6810.0

Any clue whats going on?


It looks like axon_DAQ worked fine on my axon, it prints out the values. Could it be a problem with my compiler? I've got the same setup on another computer, but it gives the exact same problems as when I do it on my. Could I have installed a wrong version of the compiler or something? I just followed the tutorial on this site.

edit: It seems like version 1.01 does not have this problem (for me). I still have to confirm that the robot is working, Im working on it atm. Will update asap.
« Last Edit: February 09, 2009, 05:32:32 AM by Tomas »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,653
  • Helpful? 169
    • Society of Robots
Re: Broken axon or maybe broken compiler? :(
« Reply #1 on: February 09, 2009, 09:14:01 PM »
Quote
It looks like axon_DAQ worked fine on my axon, it prints out the values.
This means that the Axon isn't broken or corrupted, but that there is a problem with your code.

Install the latest WinAVR and AVR Studio.

The resets are software based, something is telling it to restart or jump to the beginning of the code.

Also, try the latest version of code, but don't add your code into it. Slowly add your code and compile often until the problem appears.

 


Get Your Ad Here

data_list