Author Topic: $50 robot questions  (Read 1420 times)

0 Members and 1 Guest are viewing this topic.

Offline robotnerdTopic starter

  • Jr. Member
  • **
  • Posts: 13
  • Helpful? 0
$50 robot questions
« on: March 03, 2009, 04:36:37 PM »
OK i was trying to program the robot but the file with the code wont upload onto the Arv studios thing can anyone help me out i am at a lost.
oh and whenever i try and load it up it says there "illegal characters". can anyone help me

Offline Webbot

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 2,132
  • Helpful? 108
Re: $50 robot questions
« Reply #1 on: March 03, 2009, 06:01:39 PM »
Can you break that down? Whats an 'Arv studio thing'? I'm not sure what file you are trying to load into what eg
1. Are you loading a C file into AVRStudio but it gives an error - in which case it may have some strange character encoding
2. Are you trying to load a HEX file via AVRStudio to the microcontroller?
3. May be something else?

Please give steps of what you are doing, when you get an error and 'exactly' what it is.


Webbot Home: http://webbot.org.uk/
WebbotLib online docs: http://webbot.org.uk/WebbotLibDocs
If your in the neighbourhood: http://www.hovinghamspa.co.uk

Offline Metal Slug 2

  • Supreme Robot
  • *****
  • Posts: 333
  • Helpful? 11
Re: $50 robot questions
« Reply #2 on: March 03, 2009, 11:06:49 PM »
That happened to me before when i first tried programming my $50 robot. :P

simply go to the file what you wish to upload to you robot and rename it so that it doesnt contain any of the illigal characters (most of the time this will be 'spaces') that AVRstudio says you cannot use.  you may have to change your 'makefile' then so that it uses the renamed code.  rebuild all (to make an updated .hex file).  Then use that .hex file to program your robot.

 


Get Your Ad Here

data_list