Author Topic: Need some help with a programmer )AD-USBISP V02(-L)  (Read 1371 times)

0 Members and 1 Guest are viewing this topic.

Offline vialickTopic starter

  • Jr. Member
  • **
  • Posts: 17
  • Helpful? 0
Need some help with a programmer )AD-USBISP V02(-L)
« on: April 09, 2009, 05:45:31 AM »
I've ended up buying this programmer as it's USB and states that it can program the ATmega8. Unfortunately all the doccumentation I can find for it is in Korean, normally I can rely on my Fiancee to translate for me, but nothing technical. The google translation for the user manual is here

Unfortunately it says nothing more about the ATmega8 than it's able to program it.

After connecting it up I plug it in (green light flashing...seems better than when it had a red light flashing) and open AVR studio, and try "connect to programmer" it says a few things but then gives the error about not being able to connect to the device.

In the datasheet it shows it connected ATMega128 using PD0 and PD1 for MOSI and MISO connections, so I tried connecting it up that way (though the wires were still going to the MOSI and MISO on the mega). When using "connect to programmer" again I get some readings (some data that isn't just 0s for device signature) but still get errors when trying to do anything, such as program the device.


Is there any advice you can give me?

Offline vialickTopic starter

  • Jr. Member
  • **
  • Posts: 17
  • Helpful? 0
Re: Need some help with a programmer )AD-USBISP V02(-L)
« Reply #1 on: April 22, 2009, 08:30:31 PM »
Just a bump to say I still haven't got it working, and any help anyone could give would be appreciated :)

would it be worth buying one of the chips it gives connection instructions for (ATMega128 or ATMega16), and remaking the circuit to fit that?

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,696
  • Helpful? 173
    • Society of Robots
Re: Need some help with a programmer )AD-USBISP V02(-L)
« Reply #2 on: May 25, 2009, 06:05:36 PM »
Sorry for the late reply . . . What errors does it give?

Looking at it, it appears to have your standard 10-pin ISP connector, assuming you got the AD-USBISP. If so, just use it like I did the $50 Robot.

If you got the other connector, look for where it says 'ISP connector pinbeonho':



Otherwise, I recommend just buying the one supplied by Atmel.

Offline vialickTopic starter

  • Jr. Member
  • **
  • Posts: 17
  • Helpful? 0
Re: Need some help with a programmer )AD-USBISP V02(-L)
« Reply #3 on: June 13, 2009, 03:06:21 AM »
I guess this is what happens when I don't check forums often enough (had basically given up hope :P)

I've just packed and sent my stuff back to Australia, so it will be a month or so until I can try it again (and hope somehow I can make it work)

 


Get Your Ad Here