go_away

Author Topic: Microchip C18 Linker Problem.Help...  (Read 2830 times)

0 Members and 1 Guest are viewing this topic.

Offline twiartTopic starter

  • Beginner
  • *
  • Posts: 2
  • Helpful? 0
Microchip C18 Linker Problem.Help...
« on: April 16, 2009, 07:54:07 AM »
hello guys,when i was trying to build my project,i got this Build error message..

Code: [Select]
Clean: Deleting intermediary and output files.
Clean: Deleted file "M:\12 CCP PWM\12 CCP PWM.o".
Clean: Done.
Executing: "C:\MCC18\bin\mcc18.exe" -p=18F46K20 "12 CCP PWM.c" -fo="12 CCP PWM.o" -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
MPLAB C18 v3.20 (feature limited)
Copyright 1999-2005 Microchip Technology Inc.
This version of MPLAB C18 does not support the extended mode
and will not perform all optimizations.  To purchase a full
copy of MPLAB C18, please contact your local distributor or
visit buy.microchip.com.

Executing: "C:\MCC18\bin\mplink.exe" /l"C:\MCC18\lib" "C:\MCC18\lkr\18f46k20i.lkr" "12 CCP PWM.o" /u_CRUNTIME /o"12 CCP PWM.cof" /M"12 CCP PWM.map" /W
MPLINK 4.20, Linker
Copyright (c) 2008 Microchip Technology Inc.
Error - could not find definition of symbol 'main' in file 'C:\MCC18\lib/c018i.o'.
Errors    : 1

Link step failed.
----------------------------------------------------------------------
Release build of project `M:\12 CCP PWM\12 CCP PWM.mcp' failed.
Thu Apr 16 14:34:41 2009
----------------------------------------------------------------------
BUILD FAILED

i have checked the path to file c018i.o was correct.

Anyone any clues?

The following link is my source code.i wonder it has something to do with that.

http://cl1p.net/mplabc18/

Offline paulstreats

  • Supreme Robot
  • *****
  • Posts: 1,381
  • Helpful? 21
Re: Microchip C18 Linker Problem.Help...
« Reply #1 on: April 16, 2009, 02:58:22 PM »
have you set the path to the lib directory and the linker directory. The new version of mplab seems to make you have to do this manually no. goto:

 Project -> Build Options -> Project.          Click the Directories tabs and set the paths accordingly. the libraries path should be set to the C18 lib install folder

Offline twiartTopic starter

  • Beginner
  • *
  • Posts: 2
  • Helpful? 0
Re: Microchip C18 Linker Problem.Help...
« Reply #2 on: April 17, 2009, 08:35:13 AM »
ya,i have done that.its still not working..

 


Get Your Ad Here